Missmatched website, help ?

Hi,

I am not really new to linux or virtualmin/webmin/usermin, used cPanel for years for my websites, couldn’t pay it anymore for that, went opensource’d w/your product here, but this VirtualMin/WebMin/UserMin is just as good, if not better. I am in love with your webmin/virtualmin/usermin products! They are really good! I just got a update the other night! You guys are excellent for putting those out, I see. Thank you for keeping these systems up to date & thank you for putting out updates like that! I know a lot about computers!

I have a missmatched website on my server. I read the support issue about missmatched websites but I am still having a issue w/my 1 website. Website (1website) is pointing to another website (2website) on my webserver I have in a closet @ my house. I do not have a support team for it, I am running on Comcast Cable Internet Service, I have a Dell R210 server, very nice, fast server, on the latest version of CentOS 7.5, it also is suppose to be my master website on the VirtualMin/WebMin/UserMin server. But I do not know how to get past this issue about the 1website => 2website. its suppose to be 1website => 1website & 2website => 2website.

I hope that makes sense to you guys.

I did the ip addr sh The Output from it is : 1: lo: mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: em1: mtu 1500 qdisc mq state UP group default qlen 1000 link/ether b8:ac:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff inet 192.168.0.XX/24 brd 192.168.0.255 scope global noprefixroute dynamic em1 valid_lft 3546sec preferred_lft 3546sec inet6 2601:589:8000:XXXX::1/128 scope global noprefixroute dynamic valid_lft 53sec preferred_lft 23sec inet6 2601:589:8000:dd90:6e92:dab2:XXX:XXXX/64 scope global noprefixroute dynamic valid_lft 313984sec preferred_lft 313984sec inet6 fe80::8957:d862:XXXX:XXXX/64 scope link noprefixroute valid_lft forever preferred_lft forever 3: em2: mtu 1500 qdisc mq state DOWN group default qlen 1000 link/ether b8:ac:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff ---- I changed the IPv6 & Mac Addresses for security/privacy reasons

I did the grep -i ‘<virtualhost’ /etc/httpd/conf/httpd.conf
The Output from it is :

# ports, instead of the default. See also the # definition. These values also provide defaults for # any containers you may define later in the file. # All of these directives may appear inside containers, # If you do not specify an ErrorLog directive within a # logged here. If you *do* define an error logfile for a # If you do not define any access logfiles within a # define per- access logfiles, transactions will be

from :
https://www.virtualmin.com/documentation/web/troubleshooting#toc-500-internal-server-error-MpAQlwmk
---- I changed the IPv4 Addresses for security/privacy reasons.

I also restarted the HTTPd apache server on the server, but that didn’t fix the missmatch issue.
The Output from it is :

● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2018-11-26 17:26:58 EST; 27min ago
Docs: man:httpd(8)
man:apachectl(8)
Main PID: 1944 (httpd)
Status: “Total requests: 205; Current requests/sec: 0.4; Current traffic: 307 B/sec”
CGroup: /system.slice/httpd.service
├─1944 /usr/sbin/httpd -DFOREGROUND
├─2123 /usr/sbin/httpd -DFOREGROUND
├─2128 /usr/sbin/httpd -DFOREGROUND
├─2129 /usr/sbin/httpd -DFOREGROUND
├─2130 /usr/sbin/httpd -DFOREGROUND
├─2131 /usr/sbin/httpd -DFOREGROUND
├─2132 /usr/sbin/httpd -DFOREGROUND
├─2133 /opt/rh/rh-php70/root/usr/bin/php-cgi
├─2156 /usr/sbin/httpd -DFOREGROUND
├─2157 /opt/rh/rh-php70/root/usr/bin/php-cgi
├─2158 /usr/sbin/httpd -DFOREGROUND
├─2159 /usr/sbin/httpd -DFOREGROUND
└─3107 /opt/rh/rh-php70/root/usr/bin/php-cgi

Nov 26 17:26:46 xxxxxx.xxxxx.xxx systemd[1]: Starting The Apache HTTP Server…
Nov 26 17:26:50 xxxxxx.xxxxx.xxx httpd[1944]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using xxxxxxx.xxxxx.xxx. …is message
Nov 26 17:26:58 xxxxxx.xxxxx.xxx systemd[1]: Started The Apache HTTP Server.
Nov 26 17:26:58 xxxxxx.xxxxx.xxx suexec[2133]: uid: (1000/xxxxxx) gid: (1000/xxxxxx) cmd: php7.0.fcgi
Nov 26 17:26:59 xxxxxx.xxxxx.xxx suexec[2157]: uid: (1000/xxxxxx) gid: (1000/xxxxxx) cmd: php7.0.fcgi
Nov 26 17:29:07 xxxxxx.xxxxx.xxx suexec[3107]: uid: (1050/xxxxxx) gid: (1001/xxxxxx) cmd: php7.0.fcgi
Hint: Some lines were ellipsized, use -l to show in full.

---- I changed the Domains Addresses/Usernames for security/privacy reasons.

Please help.

Any help would be excellent.

Thank you.

Thank you,
Michael
MRGTec

Are there any conf files brought in via Include? If so, you need to check them for IP vs. * based VirtualHosts. This problem is pretty much always caused by one or more VirtualHosts configured with * when others are configured with IP addresses. So find that VirtualHost and fix it and your problem will go away.