Missing Dependency: httpd-mmn

Should I get it somewhere else or wait until your repository includes httpd-mmn?

[code:1]yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
–> Populating transaction set with selected packages. Please wait.
—> Package httpd-manual.i386 1:2.2.3-7el5.1vm set to be updated
—> Package httpd.i386 1:2.2.3-7el5.1vm set to be updated
—> Package mod_ssl.i386 2:2.2.3-7el5.1vm set to be updated
–> Running transaction check
–> Processing Dependency: httpd-mmn = 1:20051115 for package: mod_ssl
–> Finished Dependency Resolution
Error: Missing Dependency: httpd-mmn = 1:20051115 is needed by package mod_ssl

rpm -qi httpd

Name : httpd Relocations: (not relocatable)
Version : 2.2.3 Vendor: (none)
Release : 6.el5.1vm Build Date: Tue 22 May 2007 05:58:55 AM EDT
Install Date: Fri 28 Sep 2007 05:23:56 AM EDT Build Host: delilah.swell
Group : System Environment/Daemons Source RPM: httpd-2.2.3-6.el5.1vm.src.rpm
Size : 6983081 License: Apache Software License
Signature : DSA/SHA1, Tue 22 May 2007 05:59:03 AM EDT, Key ID ---------------
URL : http://httpd.apache.org/
Summary : Apache HTTP Server
[/code:1]<br><br>Post edited by: PlayGod, at: 2007/10/22 14:34

Update:

the VM package update showed up on my next login.
I did
yum clean metadata
yum clean packages
then tried the package update via normal VM Update Packages, but it still failed…

[code:1]Installing package(s) with command yum -y install httpd …

Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
–> Populating transaction set with selected packages. Please wait.
—> Package httpd.i386 1:2.2.3-7el5.1vm set to be updated
–> Running transaction check
–> Processing Dependency: httpd = 1:2.2.3-6.el5.1vm for package: mod_ssl
–> Processing Dependency: httpd = 1:2.2.3-6.el5.1vm for package: httpd-manual
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
—> Package mod_ssl.i386 2:2.2.3-7el5.1vm set to be updated
—> Package httpd-manual.i386 1:2.2.3-7el5.1vm set to be updated
–> Running transaction check
–> Processing Dependency: httpd-mmn = 1:20051115 for package: mod_ssl
–> Finished Dependency Resolution

… install failed![/code:1]

Same thing here. I did a clean install yesterday with no problems. Clean install today and I’m getting the same errors. Looks like some new packages added today here http://software.virtualmin.com/gpl/rhel/5/i386/ if that helps troubleshoot.

httpd-2.2.3-7el5.1vm.i386.rpm 22-Oct-2007 17:27 2.5M
httpd-devel-2.2.3-7el5.1vm.i386.rpm 22-Oct-2007 17:27 145K
httpd-manual-2.2.3-7el5.1vm.i386.rpm 22-Oct-2007 17:27 830K
mod_ssl-2.2.3-7el5.1vm.i386.rpm 22-Oct-2007 17:27 312K

I was having the same problem yesterday. Looks like they fixed it because today when I ran "yum update" the command completed successfully, installing the updates to httpd and mod_ssl.

Yes. Problem solved. Thanks!