Minor buglet during setup (after first reboot)

On reboot of my fresh virtualmin test, the startup scan says:

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the [list of DNS servers], or turn off the BIND feature on the $2 page.

There probably ought to be something in the $2 string :wink:

Operating system Debian Linux 10
Webmin version 1.981
Usermin version 1.823
Virtualmin version 6.17-3

To use external DNS did you check System Settings → Features and Plugins, and perhaps disable the BIND DNS Domain feature. You also need to disable BIND. For individual domains “BIND DNS Domain” feature is disabled in Edit Virtual Server → Enabled Features.

Sounds like “$2” ought to be “System Settings->Features and Plugins” or “Virtual Server → Enabled Features”

I’m just reporting that the error message says “$2” instead of a real string :wink:

1 Like

@MrPete if I remember this correctly that’s because you have no static IP configuration in your server but rather set static IP from router. just add localhost IP into records as virtualmin said and you’re fine.

Wait. Are you saying the presence of an unfilled string variable ("$2") is an indication that I am missing a config item?

If so, that is a VERY subtle error message. :wink:

I will check it out.

That’s obviously a bug.

But, that message is going away entirely very soon, so…no big deal. (I guess the bug got introduced when we softened the error to be less alarming and less demanding. But after thinking on it more, there’s just not a good enough reason to check this or have this change made, so…we’re not gonna keep doing it.)

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.