milter-greylist Version issue - Virtualmin on Centos 6

I am quite new to installing Centos 6 on Virtualmin (I used to install Virtualmin on Ubuntu). I have got a problem when I tried to setup Mail Rate Limiting feature of Virtualmin on Centos 6

When enabling this feature, Virtualmin automatically installed the milter-greylist on the server. However I failed to activate it because of the following error message:

“The milter-greylist rate limiting server is installed on your system, but is only version 4.2.7. Virtualmin requires at least version 4.3.7 to configure rate limiting”

The Centos’ default repository can only install the milter-greylist version 4.2.7. I looked at this forum and many other places in the Internet and found no clue how I can install a newer version.

Does anyone has any clue that I can get this problem solved?

I tried to enable other repositories like EPEL but no luck.

Thanks

Damen

Are you sure you are running CentOS 6? On my box I have milter-greylist-4.5.1-1.el6.x86_64, from the virtualmin repository.

What is the output of cat /etc/redhat-release?

The version is Centos 6.5 Final

Here is the output

[root@vps ~]# cat /etc/redhat-release

CentOS release 6.5 (Final)

How can I check if I have enabled virtualmin repository?

Thanks,

Damen

cat /etc/yum.repos.d/virtualmin.repo Will show the contents of the virtualmin repository configuration file.

Also what do you get from this yum list available milter-greylist

Thanks for your reply. You gave me a very important hint by telling me that there is milter-greylist-4.5.1-1.el6.x86_64 available in virtualmin repository.

I did a search and find the rpm here:
http://centos.plnet.rs/mrepo/plc-centos6-x86_64/RPMS.virtualmin/

the link to down the rpm is
http://centos.plnet.rs/mrepo/plc-centos6-x86_64/RPMS.virtualmin/milter-greylist-4.5.1-1.el6.x86_64.rpm

I used wget http://centos.plnet.rs/mrepo/plc-centos6-x86_64/RPMS.virtualmin/milter-greylist-4.5.1-1.el6.x86_64.rpm to download it to my server and get it installed.

Now I can use Mail Rate Limiting!

But I still do not understand why my server cannot access this repository. Do I have to do anything to add this repository to my server?

It’s too late, but you should NEVER just install a RPM from anywhere, always get them from a trusted repository, it is not hard for someone to modify a package to allow them to do almost anything with your system.

What is the output of cat /etc/yum.repos.d/virtualmin.repo?

Oh boy …

what is the output of this rpm -q virtualmin-release

How did you install Virtualmin on this system? Did you use the install script?

I have got no such .repo file:
cat /etc/yum.repos.d/virtualmin.repo

[root@vps ~]# cat /etc/yum.repos.d/virtualmin.repo
cat: /etc/yum.repos.d/virtualmin.repo: No such file or directory

But when I did the command:

yum list available milter-greylist,

I get this output

[root@vps ~]# yum list available milter-greylist
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile

So the package does show up in epel repository.

I still do not understand why I failed to get this installed at first time.

Hi lp86,

Here are the replies to your questions:

[root@vps ~]# cat /etc/yum.repos.d/virtualmin.repo
cat: /etc/yum.repos.d/virtualmin.repo: No such file or directory

[root@vps ~]# rpm -q virtualmin-release
package virtualmin-release is not installed

So both replies are negative.

I used the standard installation script of Virtualmin. Have I messed up anything?
I did remember there are some warnings while I was installing the Virtualmin using the offical install script. But I have not documented them.

And I was not aware the link
http://centos.plnet.rs/mrepo/plc-centos6-x86_64/RPMS.virtualmin/milter-greylist-4.5.1-1.el6.x86_64.rpm

was not the official one.

Is there anyway I can download an genuine one and then compare to my previously downloaded one by sha1sum or md5sum?

Damen

I did a search for
milter-greylist-4.5.1-1.el6.x86_64.rpm

and I have got the sha1 value in this file:

http://software.virtualmin.com/gpl/sl/6/x86_64/repodata/primary.xml.gz

I can tell from the url that this site is official, right? so can I use the value in this file for comparison?

Actually I have just done the comparison of the sha1 value and it is identical to that of the rpm file I have used to install in my server.

So I guess I am safe, right? :slight_smile:

Damen

Yes, software.virtualmin.com is the official Virtualmin repository. Our packages are always signed with either our Virtualmin GPG key or Jamie’s Webmin GPG key. The packages you found seem to be a mirror of the Virtualmin repo; which is fine as long as all the packages verify against our keys. (Keys are: http://software.virtualmin.com/lib/RPM-GPG-KEY-virtualmin and http://software.virtualmin.com/lib/RPM-GPG-KEY-webmin )

It seems like the install script either failed to setup the virtualmin.repo or the virtualmin-release package has been uninstalled at some point. The easiest thing to do would be to reinstall the virtualmin-release file. But, you may have other problems; that’s not really a normal thing, so it may be indicative of other problems.

If you’re using the GPL version of Virtualmin, you can find virtualmin-release here:

http://software.virtualmin.com/gpl/centos/6/i386/virtualmin-release-1.0-5.gpl.rhel.noarch.rpm

If using the Professional version, you’d need to login with your serial number (as username) and license key (as password) to the appropriate repository.

The install script usually does this step for you, but also does a bunch of other stuff that you wouldn’t want to run again…so it’s never recommended to re-run the install.sh script after you’ve got a functioning virtualmin system as it will do weird things (one of the weird things it can do is remove virtualmin-release, actually).