"MIgration went bad" Is there any danger installing virtalmin and migrating/restoring virtual servers using root account?

Hi guys,
i get so muddled up i suppose when setting up linux machines.
We get told to use sudo and not root, then we are told to use root (for example when installing whmcs and even control panels)

So i decided to migrate virtualmin from google cloud (debian 9) to vultr and used root account on the vultr instance to install everything (debian 9).

I also restored backups from the old server to the new one using root account.

Everything was going fine however i wasnot installing in any particular order…so the very first virtual server in the list on the old server was uploaded at number three.

As soon as i restored the old server virtual server no1, the new server shit itself and i immediately lost connection. Webmin refused to restart.

in the end i did the following…

using command prompt from vultr, i deleted the virtual server i had just reinstalled using this https://www.virtualmin.com/documentation/developer/cli/delete_domain

then i tried to restart webmin…still nothing.
Followed information from this website…https://www.quora.com/How-can-I-verify-if-Webmin-is-installed

i ran the command to check if anything was listening on port 10000 and webmin was listening but according to status command result, not running???

at this point, i went into my vultr console and restarted the entire vps. this time i see action but i am confused as to why this all happened in the first place. how can importing a virtual server stuff an entire webmin system and prevent it from working?

1 error I see is the following…

pam_unix(webmin:auth): authentication failure; logname = uid=0 euid=0 tty=

i have images of some of the above on my google drive, however as it refers to domains, i am not keen on making those public to everyone. Happy to provide access to a couple of people i trust here.

kind regards