migration of cPanel full backup is missing .htaccess files

I used the migrate virtual server option from Virtualmin to migrate my websites from WHM/cPanel. I used scp to copy the cPanel full backup onto my VPS.

The migrations seems to be succesful, however it appeared that the .htaccess files (and maybe more dot prefixed files) were missing. As a result, rewrite rules do not work anymore after migration.

I checked the full backup file and the .htaccess was present in there. So for some reason these files are not extracted. When I copy them over through .htaccess, the redirects do work again. This is quite time consuming to do for migrating all the accounts. Of course I already very happy that the migration option is there which saves me a lot of work, but if this can be fixed or if there is any workaround, please let me know (btw is this known behaviour?).

I am using Virtualmin Version 3.81.gpl on CentOS 5.5.

Would it be possible to get a copy of your backup file that we could test out?

What you’re describing shouldn’t happen :slight_smile:

So what we’d like to do is run a few tests and figure out why you’re seeing that behavior.

If it’s under 10-15MB, you can just email it to me at eric@virtualmin.com.

If it’s larger than that, perhaps you could send me a private URL that would allow me to access it?



Hmm, I’m struggling to reproduce the problem you’re seeing.

Using the backup you provided, I performed a restore, and there’s a .htaccess file in the resulting public_html folder.

Were there any errors in the output when you did the migration?

Also, how much RAM do you have in your VPS? I’ve occasionally seen odd issues when running up against the available RAM in a system.


I try it once more then. There is 512MB RAM on the VPS and I must say, it performs above expectations.
Do you know any logfiles I can examine to look for clues? I thought there were no errors when I migrated it. It’s just the files starting with a dot that were missing. Can it be a security setting maybe that blocks these files to be extracted?

I tried it once more with a different account and I have the same result. The .htaccess is missing.

I am sorry. It looks like I was mistaken. I was assuming that ls or ll would show me the files in the directory, but since it starts with a dot I had to type ls -a. I think even WinSCP was hiding it for me.
On the other host I connected through ftp, where the files were visible then.

Learning something new every day.

Thanks for your help.

Hah, that’ll do it!

No problem though.

I’ll go ahead and delete your backup from my test system here :slight_smile:

Have a good one!