Migration and aliases problem

Hi wonder if someone can point me in the right direction with slightly complex history.

Basically I am waiting to repoint an external domain readingvts.org to my server

I set up the same name readingvts.org as a virtual domain within virtualmin and created an alias www.tusla.org.uk to it (random domain I owned) so I can reconfigure the site in anticipation.

I couldn’t access the “real” domain but the alias worked fine.

I then bought a bigger server reinstalled virtualmin via the install script and migrated the domains across as per the migrate documentation. Most sites are working fine though I found the aliases seem to be mostly broken but delete and reapply seems to have fixed them.

My problem now is that the alias (www.tulsa.org.uk) works but the readingvts.org site doesn’t show on preview and I am stuck as to how to get the working site (tulsa) to be ready to accept business when I change the external DNS to readingvts.org to my virtualmin server.

I can’t seem to get tulsa.org.uk to convert from an alias to a main site.

Anyone step me through a solution?

Many thanks

“Doesn’t work” is not an error description. :wink:

Can you elaborate “doesn’t show on preview”? What exactly happens? Any errors in the Apache logs? (Note: Not all websites work properly inside the “Preview” feature, depending on how they operate internally.)

Can you also tell us what exactly happens when you try to convert that domain from an alias to a standalone site?

If you need to test your website before the actual domain name is re-routed, you can add a proper entry to your local “hosts” file, to tell your Windows (I presume) that a certain domain has a certain IP address, regardless of what DNS says. That file is usually located at %WINDIR%\system32\drivers\etc\hosts and contains some examples in addition to “localhost”.

Grrrh,

Spent all day wondering why my responses were being moderated and not appearing, til I noticed I was posting comments not replies… May show up at sometime??? Stupid me.

So, back to business.

Hi,

Doesn’t show on preview - blank screen and html is empty of meaningful content. (Its a Wordpress site)

Apache logs - nil errors reported.

Conversion - I can’t see that option (convert to standalone site) for Alias sites, only convert to subdomain under configuration? Am I missing something? (VMin 4.06 GPL)

Tried hosts file, and it gets me to the main site (readingvts.org) OK but the address bar is for tulsa.org.uk (the alias) If I remove the alias then it re-routes to another site on the server.

Not scientific but it looks like the site is invisible unless it has an alias?

Not sure how much further that gets us/me?? Keep firing Q’s and I’ll do my best to help you sort me out :slight_smile:

BW TIm

Apache httpd.conf pasted below if any help?

<VirtualHost 88.208.250.198:80>
SuexecUserGroup “#509” “#505
ServerName readingvts.org
ServerAlias www.readingvts.org
ServerAlias webmail.readingvts.org
ServerAlias admin.readingvts.org
ServerAlias tulsa.org.uk
ServerAlias www.tulsa.org.uk
DocumentRoot /home/readingvts.org/public_html
ErrorLog /var/log/virtualmin/readingvts.org_error_log
CustomLog /var/log/virtualmin/readingvts.org_access_log combined
ScriptAlias /cgi-bin/ /home/readingvts.org/cgi-bin/
ScriptAlias /awstats/ /home/readingvts.org/cgi-bin/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory /home/readingvts.org/public_html>
Options -Indexes +IncludesNOEXEC +SymLinksifOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
AddHandler fcgid-script .php
AddHandler fcgid-script .php5
FCGIWrapper /home/readingvts.org/fcgi-bin/php5.fcgi .php
FCGIWrapper /home/readingvts.org/fcgi-bin/php5.fcgi .php5

<Directory /home/readingvts.org/cgi-bin>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch

RewriteEngine on
RewriteCond %{HTTP_HOST} =webmail.readingvts.org
RewriteRule ^(.) https://readingvts.org:20000/ [R]
RewriteCond %{HTTP_HOST} =admin.readingvts.org
RewriteRule ^(.
) https://readingvts.org:10000/ [R]
RemoveHandler .php
RemoveHandler .php5
php_admin_value engine Off
IPCCommTimeout 31

AuthName “readingvts.org statistics”
AuthType Basic
AuthUserFile /home/readingvts.org/.awstats-htpasswd
require valid-user

Alias /dav /home/readingvts.org/public_html
Alias /pipermail /var/lib/mailman/archives/public
<Location /dav>
DAV on
AuthType Basic
AuthName “readingvts.org
AuthUserFile /home/readingvts.org/etc/dav.digest.passwd
Require valid-user
ForceType text/plain
Satisfy All
RemoveHandler .php
RemoveHandler .php5
RewriteEngine off

RedirectMatch /cgi-bin/mailman/([^/.])(.cgi)?(.) https://readingvts.org:10000/virtualmin-mailman/unauthenticated/$1.cgi$3
RedirectMatch /mailman/([^/.])(.cgi)?(.) https://readingvts.org:10000/virtualmin-mailman/unauthenticated/$1.cgi$3
FcgidMaxRequestLen 1073741824

Hehe okay. :slight_smile:

So that issue with your alias site is a bit hard to debug over the forum without seeing the actual system for myself, since it involves a good deal of time consuming guesswork. So first I can offer you to do a quick screen sharing session tomorrow (I’m in timezone UTC+1). If you’d like that, contact me on Skype (user “Loc2262”).

About the alias conversion: Indeed there’s no command to directly turn an alias into a parent server. But you can easily make it a subserver first and then convert that to a parent.

Hi, thanks so much for the offer, but I THINK I might have solved it in that there is a setting in wordpress that configures the display line/address. Setting that seems to have fixed things so I’ll check on various PCs and see if its fixed.

I’ll get back if needed.
BW TIm