Menu option does not show

Hello all,

I have a virtual server on one of my virtualbox machine, that does not show the “Services->SpamAssassin Configuration” option. I have disabled and re-enabled Spam and AntiVirus on the Edit Server option, but the does not show. The SpamAssassin Configuration option shows correctly for all other virtual servers.
I need to configure the SpamAssssim for that particular virtualserver.

On another server, I don’t have the Webmin->System->System Logs option.

What can I do?
Thanks

  • Rogerio Brito

Howdy,

Hmm, I wasn’t aware that there was a “Services->SpamAssassin Configuration” option – does it show up for other domains on that same server?

-Eric

Hello Eric,

Yes, it shows for all others, except this one.
I use this option to set the whitelist for each domain.
How can I fix it?

Thanks

  • Rogerio

you’ll have this options if the server is configured to run as spamassassin (Standalone program) and not as spamc (Client for SpamAssassin filter server spamd)

Hi Ronald

On Email Messages->Spam and Virus Scanning

Virus Scanning Program is set to : spamc (Client for SpamAssassin filter server spamd)

What can I do?

Thanks

  • Rogerio

Anyone, please?
Is there another way I could edit the spamassassin configuration for a particular virtual server?
Thanks

Howdy,

Well, Ronald is suggesting that setting Email Messages->Spam and Virus Scanning to " spamassassin (Standalone program)" may fix that.

If you make that change, does the option show up for you?

-Eric

Hi Eric,

Changing to spamassassin (Standalone program) did fix it.
Will there be a performance impact with this change?

Thanks

  • Rogerio

It will use additional CPU in that mode… how much a performance impact that has depends on your server and how much mail you receive.

-Eric