Mails to Hotmail (and possibly other domains) not delivered...

Hi,

I’ve got postfix working on Webmin and I can send/receive emails just fine, now, here’s the deal when I try hotmail:

I get this:

This is the mail system at host “myservername”.localdomain.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

<“user@hotmail.com”>: host mx2.hotmail.com[65.55.92.184] said: 550 DY-001
(SNT0-MC4-F28) Unfortunately, messages from “My_VPS_Public_IP” weren’t sent.
Please contact your Internet service provider. You can tell them that
Hotmail does not relay dynamically-assigned IP ranges. You can also refer
your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. (in
reply to MAIL FROM command)


Reporting-MTA: dns; “myservername”.localdomain
X-Postfix-Queue-ID: 4D9DC25ED6
X-Postfix-Sender: rfc822; “user@mydomain.com.ar”
Arrival-Date: Thu, 26 Jul 2012 20:31:04 +0000 (UTC)

Final-Recipient: rfc822; “user@hotmail.com
Original-Recipient: rfc822;"user@hotmail.com"
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx2.hotmail.com
Diagnostic-Code: smtp; 550 DY-001 (SNT0-MC4-F28) Unfortunately, messages from
“My_VPS_Public_IP” weren’t sent. Please contact your Internet service provider.
You can tell them that Hotmail does not relay dynamically-assigned IP
ranges. You can also refer your provider to
http://mail.live.com/mail/troubleshooting.aspx#errors.

Return-Path: <“user@mydomain.com.ar”>
Received: from “www.mydomain.com.ar” (localhost [127.0.0.1])
by “myservername.localdomain” (Postfix) with ESMTPA id 4D9DC25ED6
for <“user@hotmail.com”>; Thu, 26 Jul 2012 20:31:04 +0000 (UTC)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8;
format=flowed
Content-Transfer-Encoding: 7bit
Date: Thu, 26 Jul 2012 17:31:04 -0300
From: useruser@mydomain.com.ar
To: <“user@hotmail.com”>
Subject: Test
Message-ID: 9912fd60b2223d80488ad31ce1dcaee8@mydomain.com.ar
X-Sender: user@mydomain.com.ar
User-Agent: Roundcube Webmail/0.7.2

Howdy,

Well, it looks like the key is in the error message you provided there, where it says the following:

550 DY-001 (SNT0-MC4-F28) Unfortunately, messages from "My_VPS_Public_IP" weren't sent. Please contact your Internet service provider. You can tell them that Hotmail does not relay dynamically- assigned IP ranges. You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors.

Then, going to the link they provided, it explains the following:

Mail rejected by Hotmail for policy reasons. We generally do not accept email from dynamic IP's as they are not typically used to deliver unauthenticated SMTP email to an Internet mail server. If you are not an email/network admin please contact your Email/Internet Service Provider for help. http://www.spamhaus.org maintains lists of dynamic and residential IP addresses.

The IP you were provided by your ISP appears to be considered a dynamic IP.

They’re suggesting that you work with your ISP to resolve that – it’s possible that your ISP could change how that IP address is perceived.

Alternatively, your ISP could offer you another way to send messages, perhaps relating them through a mail server that they make available to you.

However, the issue appears to be specific to your IP, and the best place to start is with your ISP, and then to work from there.

-Eric

My vps provider doesnt have reverse dns. that may be the reason as well? i have read that in other forums…

The problem they’re describing isn’t related to reverse DNS – it’s specifically because your IP has been designated as dynamic.

While setting up reverse DNS can be helpful, so long as your IP address is considered dynamic, you’ll continue to have this problem.

-Eric

I may add that if an ISP can not supply rDNS, you may as well find another ISP. Apparently they are running a shady business.

even thought is not related to your issue here, you definitely should setup rdns as well, otherwise you will be blacklisted after a while (and see more rejected emails)

Ok, I checked and my ip was in the PBL so I removed it (went to http://www.spamhaus.org/lookup/ and followed the steps to remove my ip from that list), now works, but emails go to junk folder in hotmail, any ideas? could it be SPF records that I need to set up?

Next step would be to get your reverse DNS setup.

Once that is working, let us know if your emails go through.

-Eric

thanks Eric.

I made it work by adding spf records in my dns provider. I did also set up DKIM in virtualmin (I installed it because was not active by default in webmin).
as soon as i added the dkim and the spf on my TXT field in my dns provider all worked perfectly. i now get emails in hotmail and gmail main folder. I am worried though about being added again to the Pbl list as my ip doesnt have reverse dns but it works for niw at least… i will see what happens…

see my commnt below