Mailbox / home directory quotas missing (allegedly)

Hi there,

I would like to set users’ mailbox quotas for different virtual servers email users. I understand that Virtualmin sets the quotas for the user’s home directory (unix style) which includes the Maildir directory.

In Virtualmin, I select the desired virtual server on the drop down menu. Then I go to “Edit users” -> “Quotas and home directory settings”.

Unfortunately, in the quota tab, all i have is "Home directory Automatic Subdirectory of server’s home " to set the home directory path. But nothing that allows me set the quota limits in Gb.

note: the users I have tested with are ‘Email only’ and I also tested ‘Email, FTP’ users

Q1. How do I go about setting the quotas for email users?
Q2. Is there a way to set quotas for FTP users who have their FTP folder outside of their “home” folder

Thanks a million!


Users that were created as “Website access FTP users” wouldn’t have an option to set the quota.

However, standard Email and FTP users should have an option to set the quota where you were looking.

If that’s not the case – can you verify that in Edit Virtual Server -> Quotas and Limits, that you can see the quota options there?


Thanks for replying Eric. I do not see that option for email and/or FTP users.

In “Edit Virtual Server” -> “Quotas and Limits” I see these two lines:

Bandwidth limit Unlimited 10Gb every 30 days
Bandwidth usage since 20/04/2015 321.44 MB

The limit 10Gb is an editable field and the current value is what the “Account Plan” is set for

If you go into System Settings -> Virtualmin Config, does it say anything about quotas in there? It might be good to verify that it says quotas are working on /home.


Hi Eric,

When I go to System Settings -> Virtualmin Config under Server Settings this line Set quotas for domain and mail users? is set to YES.

bump :o]



Any help please?

any help anyone?

When you go to create new user for the server you should have option to set their quota but this is not available if you want to create FTP only user, in this case your only option is to set their home directory.

Thanks Diabolico. The users in question are not FTP only. Any ideas why the quota is not showing for any user?

i build a brand new virtualmin server and if i go on “edit user” ,Under “Quota and home directory settings” the “Home Directory quota” for all users is not showing. The only option available is “Home directory”. I ve seen quite a few people having the same issue, is it something that needs to be activated somewhere etc…

help needed please