Mail Still Running

I have mail for all domains completely shut off. However, the mail services are still eating up my ram. There are 6 doevecot processes running and at least 1 postfix task running as well. How would one go about getting rid of those? Is it okay to apt-get remove postfix and apt-get remove dovecot?

thanks.

edit: also, I see two clamav processes running – each consuming a LOT of ram – even though i uninstalled them.

calvin,

There are a few reasons why this may be happening.

Drop me a line at: pknowles@tpnsolutions.com and if you’d like I can assist you in troubleshooting the matter, then provide a fix based on your needs.

-Peter

Thanks for your response Peter. In order for this to be a productive and useful forum for Virtualmin users, the “diagnosing” and solution should be resolved for all to see. If you’d like to help that’d be great – if not perhaps someone else will drop by.

-Calvin

Calvin,

I was looking to offer you a quick resolution privately as I need to look over a few things, and don’t have time to go over every possible option in the forums.

If you’d like my assistance, I’m here to help, and if afterward you’d like to share the solution that’s cool.

The balls in your court :slight_smile:

-Peter

Turning off “Mail for domain” alone won’t stop the corresponding services. You need to do that additionally, while you should not uninstall the packages (might break dependencies).

First you should disable the Virtualmin Features “Mail for domain”, “Virus scanning”, “Spam filtering”, “Mailman” under “System Settings / Features and Plugins”.

Then go to “Email Messages / Spam and Virus Scanning” and disable the Spamassassing and Clamav services there.

Finally, go to “Webmin / System / Bootup and Shutdown” and disable the services you don’t need “Now and on boot”.