Mail server host name in greeting...

Howdy all,
I will apologize now, if this question has been answered and I have missed the fix!

The Subject above, is the responce from DNSReport.com when a test is performed on any of my domains.
All my mail servers(primary and virtual) are working, send and rec’v ok.
But…
I (for the life of me) cannot get a clean test at DNSReport.com. I get the feeling it is something simple to fix or change, but I am not finding it.

Layout:
Webmin,V-min(GPL)on a CentOS 4.4 server, fully updated.
Primary domain: mydomain.net
Virtual domain one: v-domain1.com
Virtual domain two: v-domain2.org

Any input would be greatly appreciated.
Thanks
Joe

Not sure what you’re asking here. I gave it a whirl and it brought up the MX record as expected. And the only problem of note, if it is, is the lack of an SPC record. According to the report the messege you’re seeing means it’s good, ok passed…in other words don’t change. :wink:

Hey Dan,
thanks for the help.
The DNSReport gives a "WARN", which means the mail should function but could be rejected on a technical violation]RFC821 4.3< by some mail servers.

The suggested fix is to put an A record in for server1.mydomain.net, which is what I am trying right now.
I will wait 48 hrs. and retest at DNSReport.

For the record:
Webmin]>> Servers]>> Bind]>> Master Zone]>> mydomain.net
ADDED: server1.mydomain.net A 123.123.123.123

Anything else I can give to clarify this?
Thanks
Joe

P.S.: sorry about the “aliased” info, wasn’t sure if my problem introduced any security risks.

Howdy again,
for anyone who comes across this thread/error, this is what resolved the problem.

Changed the Postfix SMTP Greeting Banner(smtpd_banner) from "Default" to mail.mydomain.net
Bingo!

Webmin]> Servers]> Postfix Config.]> SMTP server options]> SMTP Greeting Banner. Then made the above change.
Hope this helps.
Joe

Ah, I see. You were using Postfix. Sendmail puts it in by default. My bad. :wink: