Mail = junk problem

Hello all i need some help with my mail not sure why it keeps marking it as spam or junk on other servers i have been running centos and GLP for 1 year and the other week had the hard drive fail and lost the server.

After replacing it i reinstalled centos and the virtualmin GLP and every thing worked fine using the same setting i had last time.

Just this time the other mail servers mark my E mails as junk all the time. i have my domains hosted by godaddys. too
and as the forum category says I’m a newbie to this if you guys could help me would be awsome thx

Since you obviously know or somehow found out that the other mail servers mark your mail as spam, can you take a look at such a mail on the recipient’s end? Usually, spam filters record in the mail why it was classified as spam. SpamAssassin e.g. records (except that feature was turned off) the rules that were hit by the mail and their scores.

That way you should be able to assess what might be “wrong” with your setup that causes mails to have “spammy” characteristics.

My virtualmin email system is not receiving mail. It can send but not receive.
My inexperience is not helping very much so any suggestions would be much appreciated.

The mail systems problem report below: (expanded from
Command time limit exceeded: “/usr/bin/procmail-wrapper -o -a $DOMAIN -d
$LOGNAME”. Command output: procmail: Timeout, terminating
“/etc/webmin/virtual-server/” procmail: Program failure
(-15) of “/etc/webmin/virtual-server/”
Reporting-MTA: dns;
X-Postfix-Queue-ID: 04E60210268
X-Postfix-Sender: rfc822;
Arrival-Date: Tue, 2 Nov 2010 09:53:07 -0500 (CDT)

Final-Recipient: rfc822;
Original-Recipient: rfc822;
Action: failed
Status: 5.3.0
Diagnostic-Code: x-unix; procmail: Timeout, terminating
“/etc/webmin/virtual-server/” procmail: Program failure
(-15) of “/etc/webmin/virtual-server/”


It sounds like procmail is having trouble contacting ClamAV… what you may want to do is try restarting the ClamAV daemon to make sure it’s running properly.


My clamav seems to be out of date using version 0.96.1 when there is a 0.96.4 out here.
I can’t seem to start and restart clamav in virtualmin.
Any suggestions?


Well, it’s all about what ClamAV package is available to your distribution… some distributions have a version older than what you mentioned, so that’s not necessarily the problem.

What I’d recommend doing is trying to restart ClamAV from the command line as root, and see what, if any, errors you receive.


LibClamAV Warning*** This version of ClamAV engine is outdate.

Error local: Socket file /var/run/clamd.virtualmin/clamd.soc is in use by another process. FAILED

I can’t seem to restart the clamAV. It stops ok but when I try to restart the same warning.

It does seem to be the problem.


I’d ignore the outdated warning for the moment, that’s not the cause of the trouble you’re having. As far as the ClamAV daemon goes though – it sounds like some sort of ClamAV process is running, perhaps it’s hung in some way.

Are you able to stop it from the init scripts? If not, you may need to manually kill it using the “kill” command. After doing that, try starting ClamAV back up and see if that helps.



Good advice and it worked.

I could not at first get the clamav to restart but after rebooting the system I stopped and restarted with no problem and now the mail works fine.

Thanks for the help!