Mail id showing wrong

Operating system: Centos
OS version: 7

Hello,

In my /var/log/dovecot.log my all email id show like:

Apr 21 16:43:41 imap-login: Info: Login: user=<kumar.ask-abc.in>, method=PLAIN, rip=::1, lip=::1, mpid=565, secured, session= Apr 21 16:43:41 imap(kumar.ask-abc.in): Info: Logged out in=564 out=4105

It will show like kumar.ask@abc.in, please tell me how can i do so?

What is the email address you were expecting to see?

Kumar@ask.abc.tld?

I want to see kumar.ask@abc.in

So you want:

kumar@ask-abc.tld

But you are getting:

Kumar-ask-abc.tld

Well, the first two things you should check: if your email client is configured incorrectly and if you have entered the domain name incorrectly when creating the virtual server.

Hello
I have checked it everywhere but not found it. Can you give me any idea where to check it for it?

Who, what, why, when and where are the things that should be stated explicitly in any communication, if they are not clear to all implicitly. I am unable to understand what you mean by “I have checked it everywhere but not found it.”

I am telling you I have checked everywhere in Virtualmin setup, and I can’t found anything wrong.

Check here.
Show us your /etc/sysconfig/saslauthd

[root@webmail2 ~]# cat /etc/sysconfig/saslauthd
# Directory in which to place saslauthd's listening socket, pid file, and so
# on.  This directory must already exist.
SOCKETDIR=/run/saslauthd

# Mechanism to use when checking passwords.  Run "saslauthd -v" to get a list
# of which mechanism your installation was compiled with the ablity to use.
#MECH=pam
MECH="rimap -r"

# Additional flags to pass to saslauthd on the command line.  See saslauthd(8)
# for the list of accepted flags.
#FLAGS="-r"
FLAGS = "-O webmail2.abc.in"

OPTIONS="-c -m /var/run/saslauthd -r"
PARAMS="-m /var/run/saslauthd -r"
[root@webmail2 ~]#

According to the docs I gave you, it’s not configured with the correct FLAGS, however I’m not 100% sure that’s applicable in newer versions (as I don’t use CentOS).

But I can add that I did a quick test myself and while logging in from an IMAP client like Thunderbird, or the app on my phone, it logs in as user@domain, whilst on RoundCube it shows user-domain.
Don’t know if that’s your issue though.

Hello

So can you tell me the correct setting? I am using RoundCube. and even I also have this issue https://www.virtualmin.com/system/files/issues/support.png TLS is not working, It show “abc did not encrypt this message”

Already told you.

If installed with the install scripts, it seems RC is just looking at the usermap from /etc/postfix/virtual which also includes the user-domain users. If there’s any way to make RC make use of the user@ instead, I don’t know. Maybe ask @Joe

Different issue, please open a new thread for this.
Hint: include your /etc/postfix/main.cf right away.

created here Abc did not encrypt this message