Mail-host of Customer Domain && LetsEncrypt / autodiscover

Operating system: ubuntu
OS version: 20.04

If I create an new Virtualserver, it has the DNS-Entry for autodiscover and autoconfig.
Thats fine, but the cause of one issue:

  • no letsencrypt certificate was automatically added to mail.customerDomain.tld

I see two possible solutions:

  1. Change the autoconfig & autodiscover to a the Main-Mail-server of my virtualmin Domain, which has a valid certificate
  2. get it to work to automatically setup a letsencrypt-certificate for the mail-host of the user.

Any suggestions how to archive one of the above solutions ?

Well, that’s not what I see on my system.

Would that work at all? The mail clients (Outlook et al) will look for autoconfig / autodiscover information based on (the domain name associated with) the email address entered by the user… don’t know for sure how the email client can be made to refer to the hostname instead of the domain name. Let us know if you find a way to make this work.

I think that’s the right idea - setup a Lets Encrypt certificate - by pointing domain to the Virtualmin server IP for mail.domain.tld and also autoconfigure.domain.tld and autodiscover.domain.tld.

Well, that’s not what I see on my system.

That means at your system, the host “mail” is created, and an letsencrypt-certificate is provided?

Setting Up Virtual Server
In domain suther.niht.students.net.in

Creating home directory ..
.. done
Adding records to DNS zone niht.students.net.in ..
.. done
Adding to email domains list ..
.. done
Adding default mail aliases ..
.. done
Adding DKIM records to DNS domain suther.niht.students.net.in ..
.. added successfully
Adding new virtual website ..
.. done
Performing other Apache configuration ..
.. done
Creating SSL certificate and private key ..
.. done
Adding new SSL virtual website ..
.. done
Setting up log file rotation ..
.. done
Creating MySQL database suther ..
.. done
Saving server details ..
.. done
Re-starting DNS server ..
.. done
Applying web server configuration ..
.. done
Restarting PHP-FPM server ..
.. done
Re-starting Webmin ..
.. done
Re-starting Usermin ..
.. done
Updating Webmin user ..
.. done
Requesting a certificate for suther.niht.students.net.in, www.suther.niht.students.net.in, mail.suther.niht.students.net.in, admin.suther.niht.students.net.in, webmail.suther.niht.students.net.in, autoconfig.suther.niht.students.net.in, autodiscover.suther.niht.students.net.in from Let's Encrypt ..
.. request was successful!
Creating initial website index page ..
.. done
Re-loading Webmin ..
.. done
Applying web server configuration ..
.. done
Re-starting Webmin ..
.. done
Re-starting Usermin ..
.. done

As you can see, a Lets Encrypt SSL certificate is being created which has mail.suther.niht.students.net.in as one of the domain names for which it can be used.

Mhh, mail.domain.tld doesn’t appear at my Logs if I create an new Virtualserver.
Do you have an Idea, where I can check, why this entry for mail does not appear here?

BTW: Where would I found this “autoconfig” and “autodiscover” which is generated from Virtualmin? Is it only at autoconfig.domain.tld and autodiscover.domain.tld?
If I open that page, I was only piped to an 404 error of my webpage.

Did I need to configure my nginx to be able to access this pages?

I would hazard a guess - and I could be completely wrong about this - that older base installs of Virtualmin do not include mail.domain.tld as part of the default set of domains for which a SSL certificate is requested via Let’s Encrypt even when the base install of Virtualmin is upgraded to the current version; OTOH a newer base install (say, Virtualmin version 6.11 onwards) has mail.domain.tld as part of the default set of domains for which a SSL certificate is requested via Let’s Encrypt.

Weird, and I do believe this is a Virtualmin quirk. Again, I could be wrong and no documentation (of which I am aware) exists to confirm this but it is what I have empirically observed. So, @suther, is your install of Virtualmin an old one which you have kept on upgrading? If so, it might explain why you do not see mail.domain.tld as part of the set of domains in your install of Virtualmin while in the example I have provided from a recent install of Virtualmin, the domain is part of the set for which a SSL certificate is requested via Let’s Encrypt.

You can enable and disable this via Virtualmin -> Email Settings -> Mail Client Configuration

No.

I’ve found this setup-place to configure it. I meant what is the path which mail-clients use to receive the settings from this files? (Is it /mail/config-v1.1.xml at each domain?)

It’s a new Virtuamin installation (round about 4 Month old)

Might there be any config-setting in virtualmin (maybe for dns or hostsettings (alias domain) which is needed to create those hosts (like www. mail.) or does this happend automatically?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.