Mail format

Hello guys, I explain my problem: every time we create a user in the panel virtualmin is automatically created … we want it to have this format

Thankful for your help.

hi, you looking for Format for usernames that include domain in Server Templates -> Default -> Mail for Domain tab, you can set the username format there. But, that only is changed for new users. If you want to change existing users, you’d need to delete the account and re-add it.

its located at the bottom of the page, you want to change it to same as on picture below.


This has been answered here as well.

Hi thanks for replying, I already did that, the mails are sent with … but to be answered from any server there is an error:

… I’m sorry to have informed you that your message could not
Be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do not, please include this problem report. you can
Delete your own text from the attached returned message. …

With the format the emails are sent and answered without any problem.


well one more time same hint : that only is changed for new users. **If you want to change existing users, you’d need to delete the account and re-add it.**Once you delete that user and then (re-)add that user to domain for email, the new user login should be automatically in format USERNAME @ and not user.mydomain @

hi, The commented error is with new users, the previous user accounts were deleted. Also was tried with a new domain with the format, the problem persists when replying the mails.


well… what distro is that? also it should work for newly created users… can you create user like and I can try to send you an email. Perhaps you pop up on irc chat and we can troubleshoot it live.

The operating system is Debian 8, we have a account, you can send an email and it will be rejected, but if I can send you an email from that account without problems … at the moment I can not access a chat Irc

hi, yes you are correct however the error msgs I recieved was this:

This is the mail system at host

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<> (expanded from
    <>): mail for loops back to myself

Reporting-MTA: dns;
X-Postfix-Queue-ID: E01D221875
X-Postfix-Sender: rfc822; [hidden]
Arrival-Date: Mon,  9 Jan 2017 10:32:57 -0500 (PET)

Final-Recipient: rfc822;
Original-Recipient: rfc822;
Action: failed
Status: 5.4.6
Diagnostic-Code: X-Postfix; mail for loops back to myself

I think your config is messed up a bit, did you changed any settings? perhaps dns or some config in postfix if you done manual changes to them… I also run debian (latest version) and have no issues… also does command hostname and hostname -f respond with same output?

sorry I didnt press reply button… reply is bellow

The output of the hostname is:
root@server:~# hostname -f
Our company will host 3 virtual servers for its services, the configuration of mail is the one that comes by default when installing virtualmin / webmin

When it has the format there is no problem in sending and receiving mail.

sure then it could be dns issue… in mean time commands should respond like this:

:~#  hostname

:~#  hostname -f

If they dont, then its not set up correctly which could lead to funny issues. Your issue is that mail for loops back to myself. You can search on google but mostly FQDN causes those issues.

If is your domain you have a nice mess with your settings, Bind to point on one.

For -

  • several problems what must be sorted and can affect a lot of things, email is for sure one of them

But is using nameservers of and here we have even more DNS probelms -

- just to begin this domain doesnt resolve to any IP:

Host Name :
IP Address : cannot be resolved to an IP Address
Location : Unknown

Before email and whatever other problem you must start with Bind. Both domains reported some serious problems and its hard to pinpoint to any other problem if Bind is wrongly configured. Start from here and then go step by step to remove other problems but i’m sure just with Bind configured properly some of the problems will vanish.

Last but not least, domain is blacklisted at Not a major RBL still many are using them to check incoming emails. Either way you have open relay there, someone hacked your website or server or you are the one spamming. Not big chance because it would require a lot of emails still it could be because of wrongly configured Bind.

AqpJoe i think you have a lot of work in front of you if you want that server to function properly.

Hi, in the last hour was reconfiguring everything, so nothing works. XD … changed to the dns, I will be commenting on the result of the reconfigurations.

Fine but good part of your problems isnt Virtualmin related and a lot of info can be found on google, especially Bind, Apache and Postfix. It would be better if you sort everything and come back with Virtualmin (or Webmin) related problems. In case all this is too much for your you could pay Virtualmin devs to install Virtualmin and check if everything works properly.

Hello guys, I solved my problem by changing the domain of my server and I did configure the reverse dns with my ISP, I’m not sure if that was the problem but the mails are already working … Now I have a couple of doubts , I have two web applications in Python - Django, could you run them each for different domains? … when I run an application the following happens:

Domainone: 8990

Domaintwo: 8990

… both open the same application.

glad to hear that you resolved your problem… as I said dns can give out lot of funny issues. Regards your apps, sure you can! run one app on port 8990 and second app on different port aka 8991 or something. then in apache create two subservers like and then edit apache proxy on those… in proxy settings just point them to localhost:8990 and on another subserver to localhost:8991. Restart the apache (just to make sure new settings are loaded) and visit . it should serve app1 right a way without :portnumber.