Mail can't receive.

Hi,

Regarding the port 25 issue , I’ve updated the details.,

[root@server ~]# iptables -L -n Chain INPUT (policy ACCEPT) target prot opt source destination ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:587 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:587

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

[root@server ~]# netstat -an | grep :25
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN

Howdy,

It appears that Postfix may only be listening on localhost, and not on your public IP address.

What does this command output:

grep inet_interfaces /etc/postfix/main.cf

You would normally want that set to listen on all interfaces.

-Eric

Eric,

Thanks for the reply. Can please check the below snippet from our server.

[root@server ~]# grep inet_interfaces /etc/postfix/main.cf # The inet_interfaces parameter specifies the network interface inet_interfaces = all #inet_interfaces = $myhostname #inet_interfaces = $myhostname, localhost inet_interfaces = localhost # the address list specified with the inet_interfaces parameter. # receives mail on (see the inet_interfaces parameter). # to $mydestination, $inet_interfaces or $proxy_interfaces. # - destinations that match $inet_interfaces or $proxy_interfaces, # unknown@[$inet_interfaces] or unknown@[$proxy_interfaces] is returned

Ah, it looks like there are two “inet_interfaces” lines, there should only be one.

I would recommend commenting out this line:

inet_interfaces = localhost

And then restart Postfix:

/etc/init.d/postfix restart

After that, does your email work properly?

-Eric

Eric,

Yes , Its working fine… Thanks ! Thanks ! Thanks !