lost Mailman

I had to rebuild a box and upgraded to CentOS 4.5 before installing VirtualminPro. THen installed the virtualmin upgrades to 3.45 and the recheck configuration status appeared. When I recheck it fails claiming Mailman is not installed. I fixed the paths that were in the config but still no go. It gives the error "The mailman program /usr/lib/mailman/bin/mailman was not found on your system." Well, there is no bin/mailman, just a bin/mailmanctl

What’s up??


Found the plug-in to deselect mailman and turned it off since I don’t use it. But still wondering why the configure fails when all the structure is in place since all the other boxes are fine.

I think our mailman configuration is still wrong for CentOS–I thought it was only wrong for CentOS 3, but maybe things have shifted on CentOS 4 (that would be a bug on the part of CentOS or RHEL, since they are supposed to be "stable" platforms, but we still catch the flack from the change).

I’ll have a look.

Looks like this still needs a look; Having the same problem on CentOS 4.6/virtualmin 3.5

Failed to save enabled features : The plugin Mailman cannot be used : The mailman program /usr/lib/mailman/bin/mailman was not found on your system.

For other CentOS users, this configuration fixed the error; I haven’t tried actually creating a mailman acct yet:
(go to Virtualmin -> System Settings -> Features and Plugins, select “Configure” to the right of “Mailmain”)

Mailman base directory: /usr/lib/mailman
Mailman data directory: /var/lib/mailman
Full path to mailman command: /usr/lib/mailman/bin/mailmanctl


Full path to mailman command: /usr/lib/mailman/bin/mailmanctl

is actually wrong, as was pointed out to me after a support request. With that setting users were unable to send list messages that were being bounced.

The correct path is:


afterwhich the system works as it should.