Lost contact with server after IP change of one virtual server/host


I tried to change the IP address of one virtual server in Virtualmin, and lost contact with the server.

To reproduce, the steps I took were:

  1. Selected the domain (virtual server) from the dropdown,
  2. Under one of the submenus (I cant recall the exact menu option) I choose "Change IP address"
  3. Then I filled out the IP address of the virtual server and checked "Already active" and then pressed "update now" or whatever the button was.

Since I cant even reach the login of webmin/virtualmin I cant tell the exact steps.

I have tried to reach the server with the URL and IP, both through the browser and through ssh, with no luck. It’s important to notice that the virtual host didn’t have the same URL as the one I use for the server.

Anyone know what I can do to reach my server again?!

I have what appears to be the exact same issue. After deleting a virtual host the webmin screen times out.

webmin will no longer load from the same IP or from a remote IP.

ssh access to the server (root) also times out.

The server is still running and all virtual hosts and other services fortunately appear to be running perfectly.

After it happened I remembered that the exact same thing happened the last time I deleted a virtual host from Virtualmin (GPL)

The only ‘solution’ I can recall is to reboot the container…

Platform: Virtuozzo - centos-6-x86_64 - Webmin 1.801-1