Lost Apache w/ F11

I took the plunge and upgraded my Fedora development server today to 11. Virtualmin Pro is still intact, however httpd won’t start and produces this error message:

Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax error on line 12 of /etc/httpd/conf.d/ssl.conf: Cannot load /etc/httpd/modules/mod_ssl.so into server: libssl.so.7: cannot open shared object file: No such file or directory

Any tips on how to correct this would be appreciated.



Are you using the Pro or GPL version of virtualmin?

And, what does this command show:

rpm -qa | grep httpd

If you’re using Virtualmin Pro – one of the things you may need to watch out for is that although Fedora has a new version, Virtualmin may take a few days or weeks before it’s fully supported.

Currently, the software repo’s provided by Virtualmin only support Fedora up to version 10 (as 11 came out a little under 2 weeks ago).

This is VM Pro. I knew I was running a risk without VM being a F11 version, but for the most part it looks ok.

rpm -qa | grep httpd

Okay, so the problem you’re running into there is that the version of Apache you’re using is the one provided by Virtualmin – which does some minor modifications, including a change to suexec to have it use /home rather than /var/www.

Since Virtualmin doesn’t have an Apache version for Fedora 11 yet, there isn’t a good solution there :slight_smile:

You’d either need to jump back to FC10, or switch to FC11’s version of Apache, and either disable suexec, or compile it yourself to use /home.

But you can’t use a version of Apache compiled for FC10 on FC11 (as you have now).

The Apache shared libraries are probably failing to load (OpenSSL probably changed versions, and is no longer compatible with the mod_ssl we built against the F10 OpenSSL libs).

I have upgraded my personal machines to F11 a couple of days ago, and I’m working on F11 packages (slowly, as we have a number of other outstanding things on our todo list, and we’re at YAPC this week).

In the meantime you have three choices:

Rebuild httpd yourself

Give up on SSL until I rebuild Apache

Force an install of the Fedora httpd and give up on suexec for a while

Only the first option provides functional equivalence to what you had in Fedora 10. I’ve talked about how to do this a few times in the forums, and search will probably turn them up.

My build environment isn’t handy, so I won’t be able to tackle it until Wednesday night, at the earliest.

Thanks Eric,

Fortunately this is just my development server that I have a backup copy of VM Pro, so I’m not in any immediate crises (would never have Fedora on my hosting server).

On the hand… this is my development server so I need apache. If I go with a F11-httpd, won’t I then run into to other problems - like with FCGId?

suexec won’t work with the Fedora package. Since fcgid runs under suexec, by default, and all of your files will be owned by the user (but non-suexec will be running as Apache), it will definitely interfere with fcgid.

If you want it to be fully functional, you’ll have to rebuild the Fedora package with suexec docroot set to /home.

Thank Joe - You certainly don’t make me feel alone with this issue.

For this particular machine, giving up on SSL would not be an issue. What’s the way to do this?

This isn’t necessarily going to make this httpd run on F11. It’ll just get you past the one problem we know about. :wink:

First step would be to stop loading mod_ssl, so rename the file /etc/httpd/conf.d/ssl.conf to ssl.conf.disabled

Then use Virtualmin to disable all SSL virtual hosts on your system. If there’s anything custom in your SSL config, make a backup, as those sections will be removed when you disable the SSL sites.

Then you should be able to restart httpd without SSL errors. We can go from there.

WOW - that was easy. There’s no ssl sites or anything custom on this server. It really only has one domain on it and I build sites in subdirectories.

I renamed ssl.conf as you suggested and apache started right up.

Thanks a million Joe!