Looking for that Missing DNS piece

Hi All - first time posting here.

I’ve been working in web hosting and development for about 10 years now, so I’m not new to the field, but I am new to running my own server on my own.

I’ve been reading through the forums and documentation for a few days now, and I’m on my third tear-down and rebuild of my server and virtualmin. I think I have it set up properly now.

I’m using custom nameservers ns1/ns2.mccawleydigital.com to point to my virtualmin server I’ve gone through http://www.virtualmin.com/documentation/dns/faq and checked with my registrar to ensure my custom nameservers were set up properly.

I’ve let everything propagate for over 24 hours now, but I’m still unable to ping mccawleydigital.com which I have set up as a virtual server, and dadfrontier.com I’m also using as a test domain. Also unable to ping.

Looking at intoDNS the problem may lay with my nameservers. Can anyone give me a hand before I give up on custom NS and switch back to hover.com?

What do I check on first?

Thanks!

http://www.intodns.com/dadfrontier.com
http://www.intodns.com/mccawleydigital.com

Howdy,

Looking at intodns.com for your domains, it appears that it’s not able to contact BIND on your server.

Some examples of what could cause that – that could be because BIND isn’t running, isn’t configured to listen for connections, or maybe due to a firewall.

What is the output of these two commands:

netstat -an | grep :53 iptables -L -n

Yeah do I have to explicitly allow port 53? Any other ports? I don’t remember seeing that in any of the articles that I read through.

@ns1:~$ netstat -an | grep :53
tcp 0 0 172.30.7.100:53 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
tcp6 0 0 :::53 :::* LISTEN
udp 0 0 172.30.7.100:53 0.0.0.0:*
udp 0 0 127.0.0.1:53 0.0.0.0:*
udp6 0 0 :::53 :::*

@ns1:~$ iptables -L -n
modprobe: ERROR: could not insert ‘ip_tables’: Operation not permitted
iptables v1.4.21: can’t initialize iptables table `filter’: Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded

Howdy,

By default, there shouldn’t be a firewall running. So you’d only need to open that up if you had enabled one.

It doesn’t appear that way though, based on your above output.

It also appears that BIND is listening.

When trying to connect, the error I’m receiving though isn’t a BIND error, but a “Connection timed out”.

That does seem to suggest that something is blocking the connection.

Is it possible that your provider may be blocking those ports for some reason?

Also, is this server behind a NAT router or firewall? If so, the issue could be with one of those.

-Eric

Eric, thanks for your help. I figured over the weekend that instead of spending so much time trying to figure out these custom name servers, I was just going to use my current DNS provider to point the records for me.

This web server is not in a traditional web hosting environment, so there is an additional firewall and router that I don’t have access to. I asked him to point port 53 but nothing improved once that happened, so I abandoned custom name servers for now and everything is working great!

I’m going to continue to get more familiar with Virtualmin and add more services as I go.

Thanks for taking a look!