Logwatch reports clamav outdated

For the last two days, logwatch has been reporting:

WARNING: Your ClamAV installation is OUTDATED! WARNING: Local version: 0.92 Recommended version: 0.92.1

I have 0.92-1.vm.el5 installed. I guess that’s not 0.92.1. Is there a virtualmin update coming?

Post edited by: otis, at: 2008/02/13 03:40<br><br>Post edited by: otis, at: 2008/02/13 03:41

Yes. A day or two…

Joe,

I’m still getting the warning message in logwatch. Here’s my yum output:

yum list clam
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "protectbase" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
57 packages excluded due to repository protections
Installed Packages
clamav.i386 0.92-1.vm.el5 installed
clamav-data.i386 0.92-1.vm.el5 installed
clamav-filesystem.i386 0.92-1.vm.el5 installed
clamav-lib.i386 0.92-1.vm.el5 installed
clamav-server.i386 0.92-1.vm.el5 installed
clamav-server-sysv.i386 0.92-1.vm.el5 installed
clamav-update.i386 0.92-1.vm.el5 installed
Available Packages
clamav-data-empty.i386 0.92-1.vm.el5 virtualmin
clamav-db.i386 0.92.1-1.el5.rf rpmforge
clamav-devel.i386 0.92-1.vm.el5 virtualmin
clamav-milter.i386 0.92-1.vm.el5 virtualmin
clamav-milter-sysv.i386 0.92-1.vm.el5 virtualmin
clamd.i386 0.92.1-1.el5.rf rpmforge
clamd.clamdscan.noarch 1.0-1.vm.el5 virtualmin
clamd.clamdscan-minit.noarch 1.0-1.vm.el5 virtualmin
clamd.clamdscan-sysv.noarch 1.0-1.vm.el5 virtualmin
clamtk.i386 3.08-1.el5.rf rpmforge
claws-mail-plugins-clamav.i386 3.0.2-1.el5.rf rpmforge
fuse-clamfs.i386 0.9.1-1.el5.rf rpmforge
perl-ClamAV-Client.noarch 0.11-1.el5.rf rpmforge
perl-File-Scan-ClamAV.noarch 1.8-1.el5.rf rpmforge
perl-Mail-ClamAV.i386 0.21-1.el5.rf rpmforge

Is this a problem with having rpmforge rpms?

forgot this part:

yum update
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "protectbase" plugin
Setting up Update Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
57 packages excluded due to repository protections
Resolving Dependencies
–> Populating transaction set with selected packages. Please wait.
—> Package clamd.i386 0:0.92.1-1.el5.rf set to be updated
—> Package clamav-db.i386 0:0.92.1-1.el5.rf set to be updated
–> Running transaction check
–> Processing Dependency: clamav-server = 0.92-1.vm.el5 for package: clamav-server-sysv
–> Processing Dependency: /usr/bin/freshclam for package: virtualmin-base
–> Processing Dependency: data(clamav) for package: clamav
–> Processing Dependency: data(clamav) for package: clamav-lib
–> Processing Dependency: clamav = 0.92.1-1.el5.rf for package: clamd
–> Finished Dependency Resolution
Error: Missing Dependency: clamav = 0.92.1-1.el5.rf is needed by package clamd

Is this a problem with having rpmforge rpms?

The clam out of date warning is not. I’ll roll out new clam packages soon to fix that.

The next one is due to the rpmforge repo being enabled…you’ll need to add an exclude rule for that repo for clam*. You can’t use our Clam packages alongside the rpmforge clam packages (and you wouldn’t want to). If you want to switch to their packages, you’ll need to exclude ours. I don’t recommend it, but I’m not going to try to talk you out of it either. But, you can’t have both our repo and theirs trying to install clam–if it ever succeeds clam will break and you’ll have to clean it up before it’ll work again.

Thanks Joe!

I’m still getting reports that my clamav is out of date, only now the current version is said to be 0.93 rather than 0.92.1.

Looks like 0.92-1.vm.el5 is still the latest in the virtualmin centos5 repo