Locked out of webmin/virtualmin

I ran “/usr/libexec/webmin/changepass.pl /etc/webmin root NEWPWORD” via SSH into a CentOS 6.2 system and I am now locked out of webmin/virtualmin.

UPDATE: Ran “/usr/libexec/webmin/changepass.pl /etc/webmin root NEWPWORD” again and now I have a different password for webmin/virtualmin AND linux user root.

So I run “su” and confirm I have the correct root password. I even tried to reset the root password from within SSH

> /etc/init.d/webmin restart > miniserv.pl started > Using MD5 module Digest::MD5 > PAM authentication enabled

I try to login to webmin and I get “Login failed. Please try again.”. I try enough times and I eventually get blocked from trying again. Log shows:

> tail /var/log/secure Jul 3 01:54:40 kvm1 webmin[5587]: Invalid login as root from xxx.xxx.242.245

Would someone please help me get back in? I dont want to have to do what this user did.


Now that you’ve run changepass.pl, are you able to log in as root using both Webmin and SSH?


yes, but that was not the case the first time I ran changepass.pl