Locked my self out of webmin / virtualmin :(

I’ve managed to lock myself out of webmin/virtualmin when I was setting up a bit more security.

I was using Webmin >> Webmin Configuration >> IP Access Control

I was following the instructions and entered 192.168.1.0/25 - Hit save and had a message about cutting myself of from 127.0.0.1, so I entered 127.0.0.1, hit save, had a message about IP6 ::1 (neither localhost for ip4 or ip6 is mentioned in the instructions).

Now when I try to open webmin I get the message

403 ERROR

Access Denied For ::1

Which surprises me a little as I have IP6 disabled. Anyway, is there a “file” I can modify to stop the issue? (Just finished building the new server!)

Nigel.

1 Like

I found that if I use localhost:10000 it’s actually using the IP6 address.

So I was able to open webmin using 127.0.0.1 … and then add the ::1 to the options.

Might be worth adding a bit to the description on top of the page to make things a little clearer.

1 Like

Reminds me of when I tampered with the SSL certs trying to use a self signed one and brought down all my access to webmin. Somebody got me through it by editing a config file to be no SSL for enough time to fix the damage I did. :laughing:

I like linux, but as you rightly pointed out, it’s also very easy to shoot yourself in the foot! Sometime Virtualmin just makes it that little bit easier! :slight_smile:

1 Like