Location of Django install script on centos

Hi all,

Have a fresh install of Virtualmin (GPL) on a Centos 6.5 box. I tried to run the install script for django, but it fell over on a couple of dependencies. I added the repositories google suggested and cleared all problems except for python-psycopg. I have found and installed psycopg, and python-psycopg2, but I cannot find python-psycopg (note the numbers and dashes).

I noticed in the forum that a(n) Ubuntu user had successfully run the script, so I’m thinking it’s a distro difference problem.

In any event, could someone tell me the location of the install scripts so I can have a bit of a poke around? I had a look in the location suggested in the second post to this topic: http://www.virtualmin.com/node/19260, but I don’t have a scriptlog directory under /etc/webmin/virtual-server.

Any assistance is appreciated.

Hmm, interesting. Tried an install of Ubuntu on my VPS and ran the script again. It still falls over looking for python-psycopg, but in Ubuntu, it looks like the script then decided that python-psycopg2 would be a suitable alternative. Reinstalled CentOS on the VPS and the script fails at the install of python-psycopg and doesn’t recover.



Here 'tis: /usr/libexec/webmin/virtual-server/scripts/django.pl