local delivery : unable to receive mail on a virtual server created with virtualmin

I buyed a cloud server with centos 5.6 x64 and virtualmin builted in to admin virtual domains.

I try to create a virtual server with all enabled features ( minus SSL mnus anon FTP), included “Accept mail for domain?”

Help says:
If enabled, the server will be configured to accept email addresses to mailboxes or aliases at the specified domain. The management of mailboxes and aliases within the domain will also be enabled.

DNS of domain seems to be correct:

www A my.ip.server
mail A my.ip.server

MS 10 mail.mysite.ext.

I can access without problem via IMAP server on mail.mysyte.ext and on local server from webmail (roudcube script installed from virtualmin).

I can send email from localhost, but i cannot receive any mail!
Users that write me cannot receive any message of failure.

Where i can found mailer/message log on this problem?



You may want to check your DNS settings at intodns.com, by having them run a report on your domain. That will help show if there’s a DNS problem or not.

Also, some providers block port 25 – you may want to make sure that you can access port 25 on your server from a remote system.

Lastly – check your error logs, in /var/log/mail.log, to see if there are any errors with your mail system. If there are any problems, they may show up in there.


Thanx! DNS check was ok (except for SOA TIME to long, but trascurable now).

A telnet connection on port 25 of my mail.domain.ext are refused! :slight_smile: but service was on locally on port 25!
(using: netstat -apn | egrep ^tcp | egrep LISTEN)

How may I “open” this port through the firewall?

use webmin->networking->firewall (and the “allow common hosting ports” or so option)


Yeah, if it’s your machine that’s running a firewall, you can use helpmin’s instructions for how to open that.

If it’s your provider who’s blocking port 25 – you’d have to work out the details with them. Many providers block port 25 though, that’s not uncommon…


I have no rules set.
I have “Allow all traffic” enabled.

Is it ok?

I have no rules set. I have “Allow all traffic” enabled.

Yeah, that doesn’t sound like a firewall problem then.

What does this command output:

netstat -an | grep :25

However, it sounds like you checked into that already, so that may not be the problem… the two other things you may want to do are to check your mail logs, as well as to contact your ISP to see if they’re blocking port 25.


The output of netstat -an | grep :25
tcp 0 0* LISTEN

so i agree with you that this port was blocked by ISP… isn’t?

Regards @ all.



That actually looks like you may just be setup to have Postfix listening on your local interface.

What does this command show:

postconf -n

Now, i fix this in main.cf, “inet_interface” = All restart postfix, and now server accept mail!

That’s great!

I found that my local filesystems cannot support quotas. However I want to set bigger disk quota for mail users! is it possible “increase” this value?

Well, the Postfix settings aren’t likely to be the issue here.

If you go into Edit Mail and FTP Users, you can see if it’s attempting to enforce any quotas there. Are any of your users showing up as being over quota?


Argh! No firewall, no ISP restriction!
Tnx to your command I found that native postfix on cloud server was “closed”!!!

Now, i fix this in main.cf, “inet_interface” = All
restart postfix, and now server accept mail!

So I have another problem on delivery!
If inbox (due to IMAP mail migration) is over 51.2Mb of quota (mailbox default limit), incoming mails aren’t delivered in inbox, no message of failure was sent and mail was lost!

Where I can found more info on this postfix configs?

I temporary set bigger quota in main.cf:
mailbox_size_limit = 51200000

However, how to enable alert and/or bounce of over quota?



One other note for any troubleshooting you find yourself doing – the mail logs in /var/log/maillog, or /var/log/mail.log, as well as the procmail logs in /var/log/procmail.log, can offer a lot of assistance when things aren’t working right.