LiteSpeed with Virtualmin ?

Virtualmin does work with CloudLinux, I integrated at least 2 servers before. I didn’t had time to look into a visual GUI integration so the user has nice stats and I did everything from the command line. My main concern was making LVE work with Apache and Cage with Virtualmin and that works as long as you are willing to do some extra work. The main problem is related to suexec as CloudLinux looks for a different path, as CloudLinux ships their own patched version. Long story short you need to mount the sites path or recompile suexec with the correct path. Not only you need to use their packages but you have to recompile Apache from source. That is not something straight forward and something you would do on each update. After I recompiled Apache with the correct paths, it works.

Before this, while LVE was working, Cage was not working correctly, there was no isolation between accounts which is what you want for security.

As for Joe pointing out Virtualmin does this, this is a bit misleading. CloudLinux uses mainly open source stuff and other available tools like cgroups so technically nothing stops Virtualmin from doing something similar but that is not how Virtualmin works today (neither cPanel or Plesk or any other control panel either). The limits are per process but there is no account isolation in terms of stability or security, so Diabolico has a good point when he said he would not consider it to host production servers.

Let me make one simple example, Apache symlink race conditions, without the isolation that Cage provides, you can exploit this on basically any server and there is no real path to solve this in Apache. The fact that users can access others users files, means a compromised account can easily read another website wpconfig file for the logins details or database details. As most web apps will store logins in files it means one compromised account can compromise other sites in the same server. Read access is more than dangerous enough…for files you don’t own.

I’m sorry to say this but Virtualmin like any other control panel that just relies on Apache and other standard config files does not protect you against this. Joe even confirms this when he said FTP and the file manager is restricted to the user account but not with SSH. Actually if you use CloudLinux even when you log with SSH you can’t see other users process or files because each user has mounted a copy or clone of the systems files like a virtualization environment. So even running TOP in the command line the user only has access to his process.

The FTP restriction can easily be bypassed so can the user file manager. In a Linux environment that is just how it works. You can see other files on the systems, even if its on read mode that is enough to be a security concern with sites. This is why most providers selling shared hosting actually use CloudLinux because it solves several problems while running a multi tenant environment where you can’t trust everyone.

If Virtualmin integrates CloudLinux properly it would open itself to a new market, the commercial one or you could go directly with using container technologies like Docker in Virtualmin which solves all the above mentioned problem as it does basically what LVE in CloudLinux does but far better and more efficient. Personally I think shared hosting as it stands today has no real future because of the problems mentioned, all of them which containers actually solve. So I would instead say for now, integrate with CloudLinux but think about dockerizing virtualmin accounts in the future.

That error probably indicates some part of the configuration in the Webmin module is wrong, though I’m not sure which one. But, that’s the next step to take to solve your problem.

To repeat:

Can you start, restart, stop, LiteSpeed from within the Webmin Apache module?

It does look like it is reading at least some of the configuration file(s) correctly, but some other element of the configuration is still not matching your LiteSpeed installation, as it’s telling Virtualmin there’s no Apache webserver to configure.

Thanks @nibb for expanding the subject as i gave up, it start to look like pissing contest. Like you said it can be done but this is something i would never do on live/production server. While it could be that at some point shared hosting will become obsolete especially with VPS and dedicated prices dropping down, but we are long way from that. VPS and dedicated are like Pandora box and if the user doesnt know how to manage them he must pay someone else to do the job. While on shared hosting the client actually gets plug and play (almost) and with script installers the only thing left to do is keep updated the theme and/or plugins.

So yeah, there is still market for this kind of hosting, its huge! and i dont see in near or distant future any major changes.

Nothing stops Vm to do the same as CL but why doing this if there is already a software covering this field. Following the same logic cPanel and Plesk left this job to CL while they focused on their control panels. I still think Vm loss was huge by not accepting CL offer and like i previously said Vm literally was left out from shared or any other kind of multi user hosting. Even today that is the biggest and most used type of hosting as everything else is way behind.

I dont think Vm would beat cPanel in popularity but its one thing be left behind and another be able to grab part of the market. This become clear with Joe comment I just searched forums and issues for Cloudlinux and found three people other than you asking for it (and no Pro customers, which is not the only consideration, by any means, but it certainly helps to know people are willing to pay for software when it works the way they like). If Joe didnt realize the irony of his statement that speaks volume. Instead of offering this option to potential clients they are waiting for the clients to ask for it. But why bother with this control panel when most popular and often used cPanel offers same thing out of the box, and in case you dont want it no problem there is Plesk. Joe need to understand that he must compete with cPanel (and Plesk) and is not other way around.

I have associated these options to the correct command, so yes, when I click stop or start ; my server does that (I can check if the default page is loading or not).

Also, when I stop my server from SSH or restart it from SSH and reload the module page, the webmin module detects correctly the current status of the server.

At this point, I think it would probably waaay quicker to solve this if you would install and test on a box you control (there are free trial licenses). The back and forth here takes a lot of time. I gave my configurations of the wembin module above.

I have also changed a few settings from the litespeed control panel :
In the subsection “Using Apache Configuration File”

Load Apache Configuration Yes
Apache Binary Path /usr/sbin/httpd
Apache Configuration File /etc/httpd/conf/httpd.conf

I don’t want to sound disrespectful ; but if you don’t want to solve this tell me.

I have been patient, understanding you have a lot of things to do and you are not directly paid to solve this, but I won’t wait another three weeks to maybe have something. It’s not worth the hassle. And that’s why most people won’t even bother to try something outside the market’s leaders.

Got it. I’ll never get it done here. Uninstalled webmin & virtualmin. Bye !


Did you contacted LWS support about this? Did you contacted Virtualmin support about this? What was their response?

If not please read on…

This is a community forum, not official Virtualmin/Webmin support. If you are using the open source editions of LWS and Virtualmin, then I don’t understand your complains, those are open source free products, and usually come without any support. That is true for every other product that is free and you didn’t paid money as people (including developers) don’t put food on their tables out of thin air.

Now, if you paid the commercial Virtuamin license, then you get official Virtualmin commercial support or if you paid the LWS server edition or are leasing it, then you also get commercial support from them.

LWS works with Virtualmin and if you don’t have the proper technical knowledge to make it work, I would suggest to pay a professional to assist you.



Are not removed on uninstall and throw a “pre-existing rpmdb problem” on yum update.

You need to find the offending packages, then remove them manually and clean/rebuild yum. Assuming you are on CentOS, you can also remove packages manually but they probably have dependencies which you should not remove. It would be of more help if you post what you are trying to do exactly.

Virtualmin support told me to go to this forum.

And if you would have looked at this thread, you would understand my “complaint” (I didn’t really complain, just let know I decided to go elsewhere).

If I had been told from the start “you won’t get any kind of support”, it would have been clear. But no.

Joe ask me this or that question and tell explicitly it should be a one-time few hours things to make LSWS work with virtualmin - which could help future users. So yes, faced with this reaction, I indeed expected the issue would be looked upon, and could be fixed with a few simple steps.

At every post, I gave the most clear info I could about what was going on, often proactively. But in the end, nothing was ever done to understand why webmin’s apache module didn’t complain at all while virtualmin refused to detect the server. This discrepancy is something I can’t solve but which Joe, with first-hand knowledge of virtualmin, absolutely could have.

The end result is that I waited 3 weeks for nothing, being fed deceptive hope.

See the discussion here about cloudlinux too (which I didn’t take part in but which is interesting). Joe would like users to come use virtualmin when it doesn’t support things they need, would like them to ask to support these, and then try to support it. It works the other way around. Support what people need, and they will use your product and even pay for it. That’s even more true for professionals (which I’m not, otherwise I would have gone elsewhere day 1).

So I’m done.

At least when someone else will want to try LSWS+Virtualmin they’ll see this thread pop at the top in google and know it’s not worth to try.

I removed these 2 with yum erase.


It seems like you removed the software and already decided to use something else. I wish you the best of lucks with what ever solution you go with.

I’m working on this already if you are interested. CloudLinux told me they have no intentions and I’m not going to wait another 3 years to ask them again.

They switched the wording they told Joe before. So instead of saying not enough people are using it, they said they didn’t have enough requests from their customers. They claim it costs them $100K to support a new integration, so unless you are willing to chip in, this is never going to happen.

To be honest, I’m a bit pissed with them. They benefit from the open source community exclusively and don’t support even 1 single open source control panel. But you know what? I don’t plan to invest a lot or putting hope on them, I may use CloudLinux with Virtualmin as a temporary fix but not a permanent.

Even if they do ever support Virtualmin the integration is going to be a poor one and always lacking. They even prioritize features for cPanel only leaving other things like Plesk with less feature. So think about it. Do you want to pay them to be the underdog? Its never going to be on pair with what they offer for cPanel.

So this is what I will do. I will try to implement similar features in Virtualmin. And if it works, it will be native to Virtualmin. If it costs me $100K so be it. But it will be come with Virtualmin out of the box and this will cause CloudLinux a huge hole in their customer base. Why pay cPanel and CloudLinux if you can just get Virtualmin that has similar features already included out of the box? This will be their lost anyway.

If anyone wants to work on this I’m open to make it work. Joe already worked on a chroot system so that can be used as well.

1 Like

I know this post is old, but there is no reason why LiteSpeed would not work Bianca. Its just a web server…

Virtualmin creates the Apache vhosts
LiteSpeed reads the vhosts

I’m not sure if you need to have Apache running for Virtualmin to create them, but even if it does, you can still run LWS in parallel and not have traffic send to Apache. Either way, Virtualmin just creates the proper config and LWS reads it.

I suspect you where testing the open source edition of LWS. That edition CAN’T read Apache configuration files directly. Your errors also complain about Apache not working or installed which is not a LWS problem and you mentioned Webmin several times in your post. You need to create the accounts from Virtualmin, not from the Apache Webmin module.

  • So first, you should test if Virtualmin is creating accounts properly on its own. Yes?

  • Install LWS (standard or enterprise)

  • Try to create an account again with Virtualmin

  • Check if it appears on LWS

Any problem? Go back and test the previous part. Reading your posts the whole problems seems to come because you are creating them from Webmin, and not Virtualmin.