Liberty Reserve API not working with Virtualmin

I had a site that worked successfully with Liberty Reserve API on shared hosting ( cPanel ), i upgraded to VPS and installed successfully Virtualmin, created virtual server uploaded my website added mysql and everything works fine except Liberty Reserve APIs that don’t work anymore, don’t do nothing and also if i put a wrong password in them they don’t give error messages but just break the execution of the script regardless if the datas i put are right or are wrong.

Has anyone successfully implemented Liberty Reserve APIs in a website managed with Virtualmin, can you help me ?


The control panel you’re using shouldn’t matter… it may just be a matter of a missing dependency, or perhaps a path issue.

You may want to take a peek in the Apache error logs for that domain to see if the site is producing any errors that would help troubleshoot the problem.

You can find those in $HOME/logs/error_log.


i saw the error_log but found nothing that can help me, liberty reserve API uses the SOAP method, edited php.ini to write to memory instead to /tmp ( since virtualmin says that can’t write to /tmp related to clamav ) and the problems keeps to exist.

I feel that i’ll have to debug the code where if fails ( the code is perfect infact worked before but guess some server or php parameters are set wrong and so doesn’t work ).

thanx anyway for replying…