Letsencrypt issue on CentOS 8: challenge file not written

I had a very strange issue with requesting a letsencrypt certificate.
The challange failed with error:

Invalid response from http:// -removed- /.well-known/acme-challenge/g859sYD_nyjIpiGQ2FUsL5ANEZ0bIyIpHRHWrNr1XXX

The domain is OK.
Some investigation showed me that the challenge file was not written to the acme-challenge folder.

I googled and found someone mentioning that he had a similar problem and solved it by manually making the folders .well-known/acme-challenge under public_html.

So I tried this and IT WORKED!!!

Anyone else having this strange issue?

My setup:
Clean install of VirtualMin script on a fresh install of Centos 8 minimal.



Thanks for heads up.

Indeed, this was a bug that we’ve just fixed.

1 Like


I was looking at that bug right now. I’m also on CentOS 8.
Nice to know it’s a reported bug and has been fixed already.

@Ilia when will the fix be released? thanks!

We plan roll large new release (including Virtualmin) this weekend.

1 Like

Thanks for sharing this information. Glad that it was an easy fix on your side.

I can confirm that for my server, the fix of Illia on letsencrypt-lib.pl solves this issue.
Just made a new domain and the server succeeded in getting the LE certificate.

Thank you Illa.

You are welcome. We will have this functionality in upcoming Webmin release. (with just a little bit better implementation, code wise).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.