Let's Encrypt webroot 404


I’m trying to issue a Let’s Encrypt cert for a virtual server in Virtualmin. So far I’ve pointed to the correct binary (letsencrypt-auto in /opt/letsencrypt) but it fails during authorization:

Updating letsencrypt and virtual environment dependencies...... Requesting root privileges to run with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt certonly -a webroot -d gryffindor.liamdemafelix.com --webroot-path /home/gryffindor/public_html --duplicate --config /tmp/.webmin/542435_9998_1_letsencrypt.cgi Failed authorization procedure. gryffindor.liamdemafelix.com (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://gryffindor.liamdemafelix.com/.well-known/acme-challenge/LPsnuAwRmCyZW8QLnjE46Ao1g8Kl1JPTda99GB7QYNI []: 404 IMPORTANT NOTES: - The following errors were reported by the server:

Domain: gryffindor.liamdemafelix.com
Type: urn:acme:error:unauthorized
Detail: Invalid response from http://gryffindor.liamdemafelix.com
[]: 404

I tried that different times to no avail. I don’t get what I’m doing wrong. Machine is Debian 8 x64. Help is appreciated.

Interesting note, I added a domain and used Let’s Encrypt on it via Virtualmin and it worked as expected. I was doing this for the server’s hostname + Virtualmin port by adding a virtual server on the name that’s the same as the hostname and issuing one from there but it didn’t seem to work. A Records are configured correctly too.

I don’t directly know the answer, but if you wish to do a web search for it, the trick is to search for exactly this error string:


I tried it, and I noticed that the first few hits contain a lot of useful hints as to what might be going wrong.