lets encrypt issues and solution


the letsencrypt integrated in virtualmin use

CA Issuers - URI:http://cert.int-x2.letsencrypt.org/

but lets encrypt use curently

CA Issuers - URI:http://cert.int-x3.letsencrypt.org/

This is the current one.

One way to use the right one is to read the cert it indicates:

CA Issuers - URI:http://cert.int-x3.letsencrypt.org/ so you could use this embeded info in the certificate to automaticaly download the right one each time instead of hardcoding it.

**Also modifying the domain later on does not fill the VIRTUALSERVER_SSL_CA variable making external script fails to have a complete chain configured. My action upon server creation is therefor not working for ssl created with letsencrypt. **

It would be great to have a script hook also for ssl modification and not only host modification has this change external proxy/filter config as well.

best regards,

I didn’t understand your solution.

I currently have an incomplete chain of trust and I’m guessing it’s because of this…
I installed a Lets Encrypt SSL using the option in virtualmin but it doesn’t work…

What’s your solution? I need to put http://cert.int-x3.letsencrypt.org/ somewhere?


It’s now working correctly.
Once you setup your ssl, go to CA Certificate and Upload the following file http://cert.int-x3.letsencrypt.org/
This is a temporarly solution… but it worked!

Thanks! The solution proposed worked perfectly.

Looks like my ticket is a dup of this one: