Let's Encrypt certs not autonewing


In a previous version of Virtualmin there was a bug in renewing certs that has since been addressed. While the bug was happening, I issued a command to disable auto renewal on all sites so that Let’s Encrypt wouldn’t blacklist us. When the bug was fixed I re-enabled the renewals, however, I’m not sure this worked because I had a cert expire last week. How can I universally tell Webmin/Virtualmin to enable auto cert renewal on all hosted websites?

Thank you!

  • Ryan

Hi sespit… what distro you are on? on my Debian servers everything’s working as Swiss clock… my git.domain.com just did renewal 17 hours ago and no issues… also as friendly advice - make sure when you setting up auto-renewals for certs - set it up just for every two months… lets encrypt issue certs for 3 months so if renewal for your new cert will fail for some reason - you will have plenty of the time to trouble shoot it (like month or so in this case) :wink:


Thanks for the advice. This is on an Ubuntu 16.04 server, and cert renewal is set to every 3 months, so I’ll try every 2 instead.