Let's Encrypt certificate works on dashboard but not on site

System Info:

OS: Ubuntu 18.04 Virtualmin version: 6.12 Webmin version: 1.955

I added LetsEncrypt to the freshly installed Virtualmin default virtual server (and only virtual server right now) via Server Configuration > SSL Certificate > Let’s Encrypt > Request Certificate and the request for a combination of example.com, www.example.com and admin.example.com was successful.

If I go to https://example.com:10000, the certificate seems to be working as it should but if I try to go to https://example.com, it sometimes works and loads the certificate but most of the time returns the following error:


I have tried accessing the domain name without the port in different browsers and systems and noticed that this happens on all of them where even if it did load the certificate, the error pops up after a hard refresh or two. The certificate is consistent and works fine when I access it with the port 10000 no matter how many times I hard refresh.

What is causing this?

P.S. The configuration check for the server passed successfully and I ran an SSL test against the domain and it returned passed: https://www.sslshopper.com/ssl-checker.html#hostname=ssrvr.com

So I realised that I forgot to assign the ipv6 address that I have in my dns records to the default server.

Adding it fixed the issue!


This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.