Just a suggestion -> Server Template Text change

In Server Templates -> Default (or any) -> Apache, I suggest changing the option reading, “Redirect webmail.domain to Usermin?” to “Redirect webmail.domain to Usermin or custom URL below?”

You have to have that turned to Yes, so that the next option, “URL for webmail redirect” will take effect. Just reading that page made me think I had to turn off the Usermin redirect, then put the URL in. Would have saved me 1/2 hour of trying to figure out what was wrong.