Joomla problems with Virtualmin Solved

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.013
Virtualmin version 7.5 Pro
Related packages Joomla 4.27

I am posting this in case other people are having the same problems that I was having. It took me a while to find the solution but now they are solved.

I was able to install Joomla version 3 and 4 on my website and it was basically working except for 2 problems.

  1. recaphta would not work correctly–while it displayed the checkbox–it would not verify but just timed out
  2. The system could not detect if there were updates to Joomla (ver 4.26 to 4.27) or detect and install updates to Joomla extensions.
  3. Upgrade from version 3.10 to version 4.26 did not complete even though it appeared to work when I loaded up the site after the upgrade.

I think all these are related and had to do with system http requests. The PHP module Curl was not loaded on my system. Once I loaded the PHP-CURL module all the above problems were fixed.

The command to add this module, if you are using PHP 8.0 is
apt-get install php8.0-curl

I hope this helps someone as I was working on trying to solve these problems for 2 weeks.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.