Joomla not working once Virtualmin is installed

I had a Joomla WebServer on my Machine,

but since i installed Virtualmin i am no longer able to gain access to the Joomla Site neither can i gain access to phpmyadmin

Not Found

The requested URL /phpmyadmin/ was not found on this server.

this is the error i get for Joomla
mark(‘afterLoad’) : null; // Instantiate the application. $app = JFactory::getApplication(‘site’); // Execute the application. $app->execute();

Howdy,

It sounds like you’re saying you had existing websites when you ran the install.sh script?

Unfortunately, the installer is designed to be run on a fresh installation of your distro (a note which you have to agree to before it will perform the installation :slight_smile:

When there’s a live server with existing websites and/or email accounts, running the installer can indeed break things.

The configuration used to allow secure shared hosting, which Virtualmin configures, is different than a standard configuration you can by just installing Apache.

As far as phpMyAdmin is concerned, my suggestion would be to remove the parts of that which were setup before your Virtualmin installation, and then to go into Virtualmin’s Install Scripts in order to perform the phpMyAdmin installation.

Regarding Joomla – what you may want to do is create a new Virtual Server from within Virtualmin, and then move your Joomla application so that it’s within that Virtual Server.

Once you do that, if you continue to have problems, review the Apache error logs in $HOME/logs/error_log to get an idea of what isn’t working properly.

-Eric