Joomla Installation - ownership & permission

I’m new to virtualmin.

I’ve installed joomla successfully with virtualmin.

Just after it, I can not remove the “installation” directory of Joomla for making it work.
I’ve check the permission in console and found all the files & directory is owned by “root:root”
I did “chown -R username:username installation” to solved it.

Login to Joomla > Site > System Information > Directory Permissions
I found ALL the directories were “unwritable”

I did “chown -R username:username directoriesName” to solved it in console.

I would like to know if there’re any method that would made the virtualmin to do all the above console fixes by default?


Well, can you describe how you went about performing your installation? It sounds like the install may have been performed as the root user.

In general, you’d want to upload and unpack the files as the Virtual Server owner, which should keep the ownership of your files correct.


You may right about it …

I just “wget” & “unzip” in console as role …

I think i should do it like a client …


BTW, is there any script for providing the client to pre-install a CMS?

Yeah, if you’re doing all that from the command line as root… simply do a “su - VIRTUAL_SERVER_OWNER_USERNAME”, and run all those commands as the user.

BTW, is there any script for providing the client to pre-install a CMS?

That’s one of the coolest features of Virtualmin Pro – it comes with 80 some “Install Scripts” – web applications that can be installed with just a single click.

You can read about the differences of Virtualmin Pro and GPL here: