Javascript doesnt appear to be working

Hi guys,
I am unable to run google maps on my Wordpress website.

The website says there is a javascript error.

**Oops! Something went wrong.

This page didn’t load Google Maps correctly. See the JavaScript console for technical details.**

I have checked that javascript is enabled in my web browser (google Chrome) and it is.

I also get the same error when running microsoft edge.

I am not sure what i should be doing to get google maps working, i havent encountered this issue before.

This questions doesnt have anything to do with Virtualmin and you will get much better help if you post same questions in Wordpress forum.

Hi, this question have nothing to do with virtualmin/webmin. please ask advice from wp website…

I will do that, however, i have never in my entire wordpress career (about 5 years) ever had this problem with any Wordpress installation on any cpanel server. Is there any virtualmin configuration that can influence this error?

I will try stack exchange and see if i can find the source of the problem as the wordpress forum is completely useless.

so i have at least a significant part of the answer to my problem.

For the sake of others who may also encounter this issue the fix is as follows… The cause is actually quite simple

  1. First of all, it has nothing to do with Wordpress or Virtualmin directly.

  2. It is due to googles policy as of 2016 that all google maps embedded on a website must use an API key and the website must also be verified in google webmaster tools and also registered to use that key



  1. Once the above two are confirmed, then you can go into Wordpress and add the API Key to whatever theme or plugin is displaying your google map (in my case it is my website theme Dashboard>Avada>Theme Options>Contact Form>Google Map

Hope this is of help to others.

Also of great help in trying to correctly track this error down is the Google Chrome Menu>More Tools>Developer Tools ( a very simple method of problem solving browser issues, remember you need to have Developer Tools open with the actual web page you are browsing that has the problem!)

kind regards,