Issues with nginx, php and wordpress

I am new to webmin / virtualmin and am having trouble migrating my Wordpress site over. The problem I’m having right now is how to restart php.

As root I get a permission error when I try to do this:

/etc/init.d/php-fcgi-my-domain-name start

Specifically the error is: cannot create /home/one/logs/php.log: Permission denied

All of the folders in /home/one are owner www-data and group www-data. The log folder has a perm setting of 750, but even if I change it to 777 I get the same error. The user “one” is in the www-data group, however why are the perms set to 750 on the logs folder rather than 770? Write access to the logs folder to users in group are not allowed, so I fail to see how it could ever work.

I decided to use virtualmin to make admin easier, especially for email management, but so far email is not a priority.

Hi, owner and group should be user one, not www-data, so I think your problem is there… Regards permissions they are set up correctly.