Issues installing on Debian 9

Hello people,

Does anyone know if there is any issues with the Repos at the moment? I’m trying to install virtualmin on my new server but its just sitting at step one.

log shows the following:

[2018-05-01 11:18:10 BST] [DEBUG] Operating system type: debian
[2018-05-01 11:18:10 BST] [DEBUG] Operating system major: 9
[2018-05-01 11:18:10 BST] [DEBUG] Configuring package manager for Debian GNU/Linux 9…
[2018-05-01 11:18:10 BST] [DEBUG] apt-get repos: virtualmin-stretch virtualmin-universal
Spin pid is: 4549
Ign:1 stretch InRelease
Hit:2 stretch/updates InRelease
Hit:3 stretch-updates InRelease
Hit:4 stretch-backports InRelease
Hit:5 stretch Release

What I have found is if i stop the install I can no longer run a apt update it just sits there. if I remove the two virtualmin repos from my sources.lst file then it works. can anyone advise please?


No one able to help?

OK since my last try it seems like an issue with the repos. now I can browse to them fine on the box with curl so I can get to them. however if the following are in my sources.lst file apt hangs.

deb virtualmin-stretch main
deb virtualmin-universal main

and apt output…

root@nemesis:~# apt update Get:1 stretch/updates InRelease [94.3 kB] Ign:2 stretch InRelease Get:3 stretch-updates InRelease [91.0 kB] Get:4 stretch-backports InRelease [91.8 kB] Hit:5 stretch Release Get:6 stretch-backports/main amd64 Packages.diff/Index [27.8 kB] Get:7 stretch-backports/main amd64 Packages 2018-05-01-0828.16.pdiff [1,547 B] Get:7 stretch-backports/main amd64 Packages 2018-05-01-0828.16.pdiff [1,547 B] 0% [Working]

Then hangs for no reason. please if anyone can help.


I dunno. It looks like the OS repos are hanging, but if it only happens when our repos are enabled that would mean it’s something wrong on our end, though I can’t think of what. I just did some test installs on Ubuntu last night and it worked fine; so it’s maybe specific to Debian or maybe specific to the Debian OS repos you’re using (our virtualmin-universal repo is shared across all Debian and Ubuntu versions, while the virtualmin-stretch repo is unique to Debian 9, so maybe that’s where the problem lies).

I’m spinning up a fresh Debian 9 instance right now, and will do some testing.

OK, it’s a race condition, but I can’t figure out why it’s only hitting Debian 9 and only hitting now. I did dozens of test installs on Debian 9 a few months ago and never had this issue (and have never seen it anywhere else). I wonder if there’s been an update to ash that effects fork behavior.

Edit: Not ash-related. It happens under bash, too. So, an apt-get update maybe. I’m gonna have to poke around in my progress indicator library to see if I can figure out why it’s not breaking out of its loop properly.

Edit2: OK, not a race in my code, at all. It’s apt-get that’s locking up. Which you mentioned. Weird.

Dang it. apt-get in Debian doesn’t support https repositories. WTF?

OK, gonna have to roll back the change to using https for apt repos that I just made in the

If the repo are in https, you’ll need to install “apt-transport-https” before allowing the installation to run on debian.
I too was having this issue until I “apt-get install apt-transport-https” and reran the installation ignoring the warning.

Ah, that explains it. I’ve rolled back the change. The repos are signed, anyway, so it doesn’t really matter. I just figured while I was in there I’d make the change, since all of our servers have https already and it doesn’t make a big difference in performance/load.

yep that was it. as soon as I added the missing apt package to support https it all worked :slight_smile:

found another issue with opendmki now though.

Thanks, worked that out myself after trying to see what was wrong :slight_smile: