Issue with letsencrypt not being applied to website

I have installed virtual min, created virtualmin server and applied ssl certificate for the server, but it is applied to dovecot, postfix , webmin and user min but ssl website gives error when accessed “NET::ERR_CERT_AUTHORITY_INVALID”.

Also in server configuration Manage SSL Certificate it displays “This SSL certificate is already being used by : Postfix, Dovecot (host, ProFTPD”, and “Copy to Webmin” & “Copy to Usermin” buttons are visible although they should be gone

Any idea what is causing this issue or how it can be resolved.

Well, that’s seems to be a quite different problem. Use your browser to look up the certificate that is used by your website. That will probably give you a clue what the problem is.



Tried to look using browser got below error
“The certificate for this site does not contain a Subject Alternative Name extension containing a domain name or IP address.”

“There are issues with the site’s certificate chain (net::ERR_CERT_AUTHORITY_INVALID).”

But why is that “Copy to webmin” and “Copy to Usermin” buttons are still visible even after applying certificate and certificate is working for usermin and webmin but not for website

It seems like website is running on self signed certificate whereas virtualmin is applying certificate to webmin and usermin and postfix, any way to make it work for website as well

Solved it from