issue with hostname and 1st virtual server

I am using 3.66.gpl GPL on a CentOS Linux 5.2 server.

I installed VM using the install script, was prompted to enter a fully qualified hostname (for instance, 'example.com) and can now access VM on https://www.example.com:10000

home directory for example.com is /var/www/html

… so far, so good.

Now when I create a first Virtual Server: ‘example1.com’,
VM will successfully complete the creation process.

and home directory for my virtual server is /home/example1/public_html

… all is good here.

Only trouble is that example.com now seems to be also redirecting to /home/example1/public_html instead of /var/www/html previously.

Both example.com and example1.com now seem to be sharing the same home directory: /home/example1/public_html

Obviously, I must be missing an important setting here…

How can I change this and make sure that my hostname keeps pointing to the original /var/www/html?<br><br>Post edited by: gambit, at: 2009/02/26 23:09

"How can I change this and make sure that my hostname keeps pointing to the original /var/www/html?"

You don’t.
Once you create domains, they go to /home
Normally the first domain to create is the FQDN, i.e example.com.

You can just create it and it will be also under /home

/home/example.com/
/home/example1.com/

Thanks!

However, when after specifying example.com as hostname, I want to create a Virtual Server named example.com, i got this from VM:

‘Failed to create virtual server : AWstats reporting is already enabled for this domain’

What should i do?

Disable the AWstats option for the domain example.com?

hostname is normally 3 parts like server1.example.com
however you can try to switch awstats off for that domain, create the server and switch it back on.
not sure about the outcome though