Issue with Alias of <server>, with own email


I’ve added a sub server using the new Alias of with own email option but think there is a problem with it.

When I then add a new user and try to use the email, their email address comes out as name.domain@hostaname, e.g.

If I use Usermin to send an email it does work, but the From email address is not as I would expect it to be

Any ideas if there is a setting somewhere that I’m missing?

Thanks in advance for any help


As a side note to this I’ve just noticed the parent domain does not run email, its handled by a third party, could this be part of the problem?

Please ignore, I think I’ve fixed it!

Firstly I had to turn on Mail for the parent domain - as far as I can tell this won’t impact on that domain as the DNS is handled externally and points the MX records to Google Apps.

I then had to go to Webmin > Servers > Postfix Mail Server > Virtual Domains and add a record for my mail account, its a shame this isn’t handled automatically, perhaps something to look at by the devs but maybe its just my set-up?

Finally I needed to add the alias domain to the file, under Webmin > Servers > Postfix Mail Server > Edit config files find the mydestination line add the domain at the end. Again I would expect the system to handle this as it does normal domains/servers - is there a alias type that would handle all alias servers?

Restart Postfix and for me it all now seems to be working!


I’m glad you got it sorted out, thanks for letting us know how you fixed it!