Issue while converting Alias to SubServer

OS type and version: Ubuntu 20.02
Webmin version: 1.981
Virtualmin version: 6.17

I have an issue with converting an Alias to a subserver.

I don’t see what for this .cloud-locale-test.skip file is, as I don’t use cloudmin.
Any suggestion what the issue here might be?

If I manually create this file, and give them user + group permissions of the user, I got the next error-message:

Home directory failed! : Failed to open /home/xxxmoto/domains/ for writing : Permission denied

That’s nothing to do with Cloudmin (or Virtualmin).

Googling that name says it’s a cloud-init file, which has nothing to do with us, and we have no familiarity with it.


There is new you can have /use cloudinit.

ok, but at least that … and after if that file was manually created, .bash_logout is missing.
I don’t try it further to see if there are other files missed too, after creating .bash_logout.

But I think if that blocks converting an alias to an subserver, we might should catch this by virtualmin and create those empty files, so that the converting can successfully run?!

@jotst sorry, don’t get what you mean.

Is your hoster Contabo?
Then they use cloudinit maybe.

Other hosters could use this to in the images.

Ah, now I got it.
No, it’s an own server. I don’t use cloudinit.

Is the domain out of quota? Seeing permission denied for any file creation is often that.

But, again, the .cloud-local-test.skip file definitely didn’t come from us. I don’t know where you got it from. Maybe it’s in your /etc/skel? You should figure out where unexpected files on your system came from.


Any “.cloud” is typically an artifact of the way a VPS provider deploys their VPS’, especially when it comes to Ubuntu who has done a lot of cloud optimizations to their distro.

@Joe @tpnsolutions
Ok, I’ve tried it again with another Main-Domain at the same server, now it work like expected.
Don’t know what exactly was the issue, as I didn’t anything else as before, but fine that all is working as expected now.

So the issue is solved. Thanks.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.