Issue after server backup restoration

Hi All

I’ve stumbled across some weird behaviour with which i am stumped on how to go about rectifying.

So I’ve just restored my sites back onto the server, all sites have restored just fine except one. The restore process completed successfully but when i point the browser to the site I get the following error message:

“The page isn’t redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

So, I have tried deleting the server and restoring the backup again, still does the same thing. I’ve cleared browser history (including cookies), still nothing. I’ve looked in the redirect sections and cant see anything in there, I’ve removed the SSL and requested a new, still nothing. I’ve looked through all the logs i can think of, and cant find any reference to anything in those.

The weird thing is, it worked just fine before!

So I’m at a bit of a loss of how to get to the bottom of this one, any ideas would be really appreciated, the site is:

hi thammond1983!

Perhaps you could try to rename .htaccess to something like test.htaccess if you use apache and then try to reload the site to see if its working or you would get some error code. Also you did not said if that is wp site or any other cms. I would start from there. If renaming of .htaccess give you 404 or 500, or no error at all, you should have look at it and make some corrections to it. Most of the times its invalid entry there or in db (in a case your site is cms). I would also check apache errors log (its located in virtualmin under domain which have trouble)… Also is the backup from apache2.2 restored to apache2.4? What OS is your server running? centos, ubuntu, debian… ? It may sounds stupid but even debian and ubuntu have different configs for those things.

the currently in my browser your site in a question gave out:

thanks for contacting me thammond1983, I am glad that we sorted your issue and everything is working! Also sorry for time I’ve taken while testing it…

Have good day sir!

I have the same issue. Would you care to share? " I am glad that we sorted your issue and everything is working" - How?