ISP problem (BT)

|Operating system |CentOS Linux 7.9.2009|
|Webmin version |2.001|
|Usermin version |1.860|
|Virtualmin version |7.3 Pro |

HI all,

Just wondered if anyone else is having problems with users unable to send email when using their BT connection (for the uninitiated BT is a UK ISP). No error messages just times out when sending. Receiving is ok.

When the user uses another non-BT connection, all is fine.

User1. Can’t send when at home using their BT connection but it works no problem when she took her Apple laptop the apple store. Also works if she uses her mobile (not BT) as a local hotspot at home and away. Visits a friend and it works there (not BT). Has a cousin (not our client) with BT who has the exact same issues.

User 2. Has two internet connections at home, one BT and the other not BT. Non BT connection works but the BT one doesn’t. Also visits son in another town with a BT connection and it fails again.

The ONLY common factor I can find is that BT is the ISP. I have checked that the server has no blocks on their IP numbers.

I’m kinda guessing that BT has for some reason blocked access to our server IP number but trying to get anywhere with their support is useless and how I have tried. Mostly won’t speak to me because I’m not a customer so I asked “What if an ISP has problems with BT who do they speak to?” The guy replied “What’s and ISP?”. Perhaps I am expecting too much.

Anyway, does anyone else have similar problems with BT?

Thanks for reading.

1 Like

I use BT & have no issues sending & receiving emails from my server using thunderbird. do you have a hh5 or a smart hub ?

BT may not be blocking the IP address but maybe blocking ports.

A way to test would be to do a manual connection and you’ll find out.

You’ll need the mail SMTP connection info - instructions at



Not blocked for me on BT …

Tried to break this any way I could no success … It works every time but I am not sure here if the MTA is on a BT domestic IP address or a non BT IP address … My guess is the mail client is using BT services to connect to a remote server (non BT) if this is the case why not connect via your email client while tailing the mail log in another window you should see something … Do you have any of the BT ‘utilities’ running ?

The server is not running here but in a data centre owned by the company I rent it from so I have no idea, I will have to contact them.

These are end users with no technical knowledge at all and unfortulately they wouldn’t be able to do a telnet session but thanks for the thought.

The server is not on a BT connection (as above) but in a data centre. I did watch the logs when one of our customers tried to send an email but there was nothing to suggest that there was even any attempt to make any connection at all. Sorry, I have no knowledge of BT ‘utilities’. I will do a google.

However, I finally got past BT’s refusal to talk to me by emailing the CEO. Got things moving but not achieved anything of a resolution yet. I suspect that since it is late on a Friday, I will hear nothing more until Monday.

Many thanks for your replies, greatly appreciated.

I appreciate they might not but you could use something like Teamviewer to remote on to their laptops\desktops and have a go yourself.

Many thanks. I did try that but could not connect to the server on any of the mail ports. Other ports ok.

Yesterday morning I received a mail from one of the clients saying that he can now send. Later, I received email from anotrher, their problem had also gone away.

Not heard from BT yet, probably won’t but the important thing is the issue is resolved.

Thanks again for all your input.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.