Isn't take quite a long time on Enabling quotas on filesystem /home while installation

I just rented a dedicated server hosting, with following configuration
250GB hdd
dual core intel cpu

The OS is installed by the hosting company and it is CentOS 5.5.
After they gave me back the control of the server, i installed virtualmin

However I found it take very long time on “Enabling quotas on filesystem /home”

More than an hour still not completed at this message.

What output do you get if you run these commands:

  1. df -h

  2. mount

Also, if you look towards the end of /root/virtualmin-install.log, do you see any errors?


When I was waiting for it completion , i was received a system restart signal at my remote console.
Probably the technical people from hosting force a restart remotely.

Then I lost my connection and I can’t connect to the server for a while.

When I am able to connect to the server again, I checked the log and found some error message regarding quotas

Setting Webmin theme
Setting Usermin theme
Error occurred while setting Usermin theme: Failed to open PID file at …/web-li line 1340.

Configuring Postfix
Enabling Postfix and disabling Sendmail
Setting up freshclam
ClamAV update process started at Fri Jan 14 11:29:45 2011
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
Downloading daily.cvd [ 4%]
Downloading daily.cvd [ 7%]
Downloading daily.cvd [ 11%]
Downloading daily.cvd [ 14%]
Downloading daily.cvd [ 18%]
Downloading daily.cvd [ 22%]
Downloading daily.cvd [ 25%]
Downloading daily.cvd [ 28%]
Downloading daily.cvd [ 35%]
Downloading daily.cvd [ 39%]
Downloading daily.cvd [ 42%]
Downloading daily.cvd [ 45%]
Downloading daily.cvd [ 49%]
Downloading daily.cvd [ 53%]
Downloading daily.cvd [ 56%]
Downloading daily.cvd [ 60%]
Downloading daily.cvd [ 63%]
Downloading daily.cvd [ 66%]
Downloading daily.cvd [ 70%]
Downloading daily.cvd [ 73%]
Downloading daily.cvd [ 76%]
Downloading daily.cvd [ 80%]
Downloading daily.cvd [ 83%]
Downloading daily.cvd [ 87%]
Downloading daily.cvd [ 91%]
Downloading daily.cvd [ 94%]
Downloading daily.cvd [ 97%]
Downloading daily.cvd [100%]
daily.cvd updated (version: 12519, sigs: 16125, f-level: 58, builder: ccordes)
Downloading bytecode.cvd [ 21%]
Downloading bytecode.cvd [ 32%]
Downloading bytecode.cvd [ 43%]
Downloading bytecode.cvd [ 56%]
Downloading bytecode.cvd [ 67%]
Downloading bytecode.cvd [ 82%]
Downloading bytecode.cvd [ 96%]
Downloading bytecode.cvd [100%]
bytecode.cvd updated (version: 117, sigs: 29, f-level: 58, builder: edwin)
Database updated (862368 signatures) from (IP:
Configuring Dovecot for POP3 and IMAP
Enabling Dovecot POP3 and IMAP servers
Enabling ProFTPd
Starting proftpd: [ OK ]
Enabling SMTP authentication
Starting saslauthd: [ OK ]
Configuring Virtualmin
Configuring Procmail
Configuring Webalizer
Updating /etc/shells
Enabling MySQL and PostgreSQL
Enabling Apache
Configuring and enabling BIND
Configuring resolv.conf to use local DNS server
Configuring and enabling Mailman
Enabling status monitoring
Hiding the Webmin upgrade page
Error occurred hiding Webmin upgrade page:
convertquota: Quota file not found or has wrong format.
convertquota: Can’t open old format file for users on /

error: %post(virtualmin-base-1.0-61.rh.noarch) scriptlet failed, signal 1

virtualmin-base.noarch 0:1.0-61.rh

Dependency Installed:
GeoIP.i386 0:1.4.7-0.1.20090931cvs.el5
awstats.noarch 0:6.8-1.el5
clamav.i386 0:0.96.5-1.vm.el5
clamav-data.i386 0:0.96.5-1.vm.el5
clamav-filesystem.i386 0:0.96.5-1.vm.el5
clamav-lib.i386 0:0.96.5-1.vm.el5
clamav-server.i386 0:0.96.5-1.vm.el5
clamav-server-sysv.i386 0:0.96.5-1.vm.el5
clamav-update.i386 0:0.96.5-1.vm.el5
cyrus-sasl-md5.i386 0:2.1.22-5.el5_4.3
fedora-usermgmt.noarch 0:0.9-1.el5
fedora-usermgmt-core.noarch 0:0.9-1.el5
fedora-usermgmt-default-fedora-setup.noarch 0:0.9-1.el5
fedora-usermgmt-shadow-utils.noarch 0:0.9-1.el5
mod_fcgid.i386 0:2.2-1.el5.vm
procmail-wrapper.i386 0:1.0-1.vm
proftpd.i386 0:1.3.3c-1.el5.vm
scponly.i386 0:4.6-1.vm
usermin.noarch 0:1.460-1
ust-virtual-server-theme.noarch 2:6.9-1
wbm-php-pear.noarch 2:1.5-1
wbm-ruby-gems.noarch 2:1.4-1
wbm-security-updates.noarch 2:4.0-1
wbm-virtual-server.noarch 0:3.82.gpl-1
wbm-virtualmin-awstats.noarch 2:4.4-1
wbm-virtualmin-dav.noarch 2:3.3-1
wbm-virtualmin-htpasswd.noarch 2:2.3-1
wbm-virtualmin-init.noarch 2:2.1-1
wbm-virtualmin-mailman.noarch 2:5.9-1
wbm-virtualmin-registrar.noarch 2:2.0-1
wbm-virtualmin-svn.noarch 2:4.7-1
wbt-virtual-server-mobile.noarch 2:2.3-1
wbt-virtual-server-theme.noarch 2:7.8-1
webmin.noarch 0:1.530-1


Now, I’m not sure installation of Virtualmin is fully success or not.

It looks like it did complete, but that it wasn’t able to setup quotas on your server.

I’m not sure why that is… that’s an issue that sometimes comes up on certain VPS’s, but you mentioned that you’re using a dedicated server. Another possibility is that something is unusual about the filesystem your server has, and that Virtualmin doesn’t support it. You’d have to run the two commands I mentioned above for me to figure out that possibility though :slight_smile:


Here it is

df -h

Filesystem Size Used Avail Use% Mounted on
/dev/hda3 449G 2.9G 423G 1% /
/dev/hda1 994M 45M 899M 5% /boot
tmpfs 949M 0 949M 0% /dev/shm


/dev/hda3 on / type ext3 (rw,grpquota,usrquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

From the output of df,

the partitioning of the centos is just standard linux parition instead of lvm, isn’t it a problem of that ?

I tried to login in virtualmin, but the page look a little bit weird.

It look different from my local development machine

And I found also bin and cron_scripts folder and bunch of files inside, under root account home

The theme isnt working or isnt installed. that is why the page looks odd.

the files have been put there by your ISP, probably to keep control of your machine in case of troubles

New update regarding this issue.

I just configured everything in virtualmin and create the first virtual server…but failed.

Failed to create virtual server : setquota: Quota file not found or has wrong format. setquota: Not all specified mountpoints are using quota.

While I reading this post

and executed, repquota -uga
it returned
repquota: Quota file not found or has wrong format.


i also found that virtualmin cannot create database

Creating MySQL login …
… MySQL database failed! : SQL flush privileges failed : Table ‘mysql.servers’ doesn’t exist at …/ line 1340.

It seems that there are something broken during the installation.

Hrm, something very unusual is going on :slight_smile:

Are you certain you’re working with a dedicated server and not a VPS?

Also, what yum repositories are setup there? You can determine that by looking in /etc/yum.repos.d. The MySQL error you’re seeing is what you’d typically receive after performing a major MySQL upgrade… which wouldn’t make sense when performing a typical install. But I might expect that sort of thing if a third party repository containing a newer MySQL were enabled…


Hi im getting the same mysql error after upgrading to php 5.2

Now i cant connect to database and when i try to create a new virtual server i get this:

MySQL database failed! : SQL flush privileges failed : Table ‘mysql.servers’ doesn’t exist at …/ line 1340

i hace a dedicated server too, what can i do to solve it please?

Hmm, it sounds like more than just PHP was updated there… that sort of problem can also happen if MySQL was unexpectedly upgraded.

Check out this thread here for details on fixing that particular problem: