Is my dovecot.conf incomplete?

Operating system CentOS Linux 7.9.2009
Webmin version 1.973 Usermin version 1.823
Virtualmin version 6.16 Authentic theme version 19.73

I think this is more of a general query rather than a problem to be solved.

Owing to an extraneous bracket in the local_name section of dovecot.conf, my Dovecot server would not start following a recent update of many items - bind,kernel…, I removed the bracket and solved the issue.

Out of interest I checked the dovecot.conf of another server I have, same specs, and found there are no local_name entries in it at all. As with the original server, I have LE SSL certs set up for all virtual servers on this second instance.

I’m curious as to why there are no local_name entries in dovecot.conf. All email appears to be operating correctly. Should I be concerned?

On further inspection, it seems that the settings in

SSL Certificate > Service Certificates might dictate whether or not there is a local_name entry in dovecot.conf.

I’ll do some more checking.

The version of dovecot also determines whether it gets local_name directives. Older versions simply don’t support SNI, so local_name would be nonsensical.