IPCCommTimeout setting in VM

Where can I set the IPCCommTimeout in VM?

The default of (I think) setting it based on PHP max_execution_time is woefully incorrect. max_execution_time is CPU time and defaults to 30 seconds (reasonable for most environments).

But IPCCommTimeout is wall-clock time. Hence process exit after 31 seconds of clock time if there’s been no data. Way too short.

If max_execution_time is to be used as a basis, I’d suggest IPCCommTimeout be set to max_execution_time * 20 or something.

But still need to know where to set it up in my templates so that new servers are created with a reasonable time.

Hi Tony,

You should be able to set that in the Server Templates – you can find it in System Settings -> Server Templates -> Default Template -> Apache Website.

And then, in "Directives and settings for new websites", feel free to modify that to whatever best suits your environment.

Hi Eric,

The setting is not in my defaults. Hence I don’t know where it’s being included from (assumption is that Jamie made a change that picks up max_execution_time. If I set it in the template, will the override whatever the default is for the VM system?

This setting is somewhat hard coded in the php-lib.pl script that is called when a server is created. Here are the comments from the file:

(on ubuntu, that script is located in: /usr/share/webmin/virtual-server/)

#For fcgid mode, set IPCCommTimeout to either the configured value
#or the PHP max execution time + 1, so that scripts run via fastCGI
#aren’t disconnected

According to the code, if the value fcgi_max is set to anything at all, it will use that value, otherwise it takes the php_max_executiontime and adds 1 to it, and makes it the value in server config.

Or just set the php max to what you want the IPCComm to default too…

Now the next question is if we can set the value elsewhere to avoid the +1 default…