Invalid host or serial number A renewal can be purchased at Virtualmin Shop

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Virtualmin version 7.2-1 Pro
Related packages SUGGESTED

I never had pro on this machine and after an update I started getting this warning.

I tried to fix it with “# yum downgrade wbm-virtual-server-7.2-1.gpl-1 # service webmin restart”
It did not throw an error but the problem still persists.


Search the forums, this is likely due to a recent issue where @Joe accidentally released the Pro version into the GPL repo. This has been asked and answered a few times.

I noticed that and tried the YUM solution and it didn’t work. I gave up too quickly I guess. To be fair I am only experienced with APT.

My solution is:

sudo apt update
sudo apt install webmin-virtual-server=7.2.gpl-1 -y --allow-downgrades

yum does not exist on Ubuntu. And, usnig yum is not the advice I gave for this situation.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.